Pyramix display blurry

Welcome to the Pyramix MassCore discussion forum.
Forum rules
The Merging Technologies team cannot be held responsible for support queries logged on the public forums. If a support query is logged here and only here, it may not be found and dealt with by the appropriate team.
To ensure that your support issue or bug report is dealt with properly and in good time, please use the link to the tech support request form page on the Merging website.
Make sure to let us know what version you are using when you send your mail. THANKS!
musicianroc
Posts: 9
Joined: Mon Oct 02, 2017 16:18

Pyramix display blurry

Postby musicianroc » Mon Jun 24, 2019 03:07

Hey, guys. I'm using a 1920*1080 resolution laptop for my Pyramix, but realize that the fonts for PMX look blurry if I set the system display as 125% as it recommends, however, it looks correct when I force the system display to 100% but it looks quite small in Pyramix...hurts my eyes...

May I ask for some suggestions from you guys, see if there is a solution to this? Is it only the 125% but blurry or you guys all using the 100% for the system but just get used to it?

Thank you all!

User avatar
fl
Posts: 1323
Joined: Sun Feb 11, 2007 19:55
Location: Toronto, Ontario, Canada
Contact:

Re: Pyramix display blurry

Postby fl » Mon Jun 24, 2019 16:31

As someone who has struggled for years with the tiny fonts used by Windows, as well as getting nose prints all over my monitor from squinting to see what is being displayed in Pyramix, I feel your pain.

You've discovered that using the Windows Control Panel > Display setting to anything other than 100% is not optimal. There are also issues with Pyramix where anything but 100% will make the type too large to be displayed within some of the fixed size boxes or windows where type is shown, such as the Time Code locations (with the dark grey backgrounds) shown in the Toolbar above the Tracks in the Main Window. However, the only font size you can adjust within Pyramix is that used to label the Clips in the main Settings > Application > Timeline Layout, where I selected "Large".

For everything else, the best trade-off I've arrived at is to set up a custom Theme in Windows' Control Panel > Personalization. Sadly, this is only available in Windows 7 (and maybe 8). I'd love to learn how to set this up in Win10.

1. Open Control Panel > Personalization
2. Click on "Window Color" at the bottom
3. In this window, click on "Advanced Appearance Settings".
4. In the small window which opens select, in turn, "Active Title Bar", "Icon", "Inactive Title Bar", "Menu", "Message Box", "Palette Title", "Selected Items" and "ToolTip", and set the font to "Segoe UI SemiBold" at "12" points for each.
5. Okay and close the window
6. Back in the Color and Appearance window, save your changes to return to the main Personalization window.
7. Make any other changes you wish (Desktop Background, Sounds, and Screen Saver), and then save as a new, custom Theme with a suitably descriptive name.

I've found that the Segoe SemiBold is the best of the bunch for legibility, and that 12 points is about as large as you can make it before it starts to impact Pyramix adversely. Be prepared to do more scrolling in drop-down Menus. There will still be certain programs - installers for the most part - that do not display everything you need to adjust because the window is a fixed size and there are no scroll bars (Izotope installers are the chief offenders here). However, a quick visit to the Personalization CP to switch to one of the stock Themes will allow you to interact with these programs properly, before returning to your custom Theme for improved legibility.
Frank Lockwood, Toronto, ON, Canada
http://LockwoodARS.com
• Pyramix Native
• Mac Mini 6.2 (Quadcore i7) - Bootcamp 5.1.5621 - Win7 Pro SP1 64
• HP 7100 Mini-tower - Win10 Pro 64 1809
• RME Fireface 800 ASIO driver 3.125 or ASIO4All 2.13

User avatar
fl
Posts: 1323
Joined: Sun Feb 11, 2007 19:55
Location: Toronto, Ontario, Canada
Contact:

Re: Pyramix display blurry

Postby fl » Tue Jun 25, 2019 20:54

I found an answer for Win10.

All you can do in the Settings, is increase the size of everything by scaling. Pyramix gets a little unwieldy when it's all puffed up like that. A better option IMO, is just to change the size of the display text:

Download Advanced System Font Changer from https://www.wintools.info/index.php/adv ... nt-changer

It couldn't be more straight-forward. When the program first opens, you are asked to save the current default settings, which is a good idea. Once that's done you're taken to a window displaying the six current System Font settings. The default font is Segoe UI already, so all I had to do was select each one in turn, change its Font Style from "Regular" to "Semibold", and its Size from 9 to 12. Click on "Apply", quit the program, and sign out and then back in to Windows, and it's done. I can now enjoy the same level of legibility in Pyramix under Win10 as I could under Win7.
Frank Lockwood, Toronto, ON, Canada
http://LockwoodARS.com
• Pyramix Native
• Mac Mini 6.2 (Quadcore i7) - Bootcamp 5.1.5621 - Win7 Pro SP1 64
• HP 7100 Mini-tower - Win10 Pro 64 1809
• RME Fireface 800 ASIO driver 3.125 or ASIO4All 2.13

musicianroc
Posts: 9
Joined: Mon Oct 02, 2017 16:18

Re: Pyramix display blurry

Postby musicianroc » Tue Jun 25, 2019 22:01

Thank you so much for such a detail explanation, Frank. I'll go ahead and try it out.

fl wrote:I found an answer for Win10 1803 Creators Update - which is the system we're all supposed to be running in order to be compatible with Pyramix 11.1.5. Apparently earlier versions of Win10 had a font size slider in the Ease of Access Settings but, well, you know, Microsoft and progress...

All you can do in the Settings, is increase the size of everything by scaling. Pyramix gets a little unwieldy when it's all puffed up like that. This is a better option IMO, in that it just changes the size of the display text:

Download Advanced System Font Changer from https://www.wintools.info/index.php/adv ... nt-changer

It couldn't be more straight-forward. When the program first opens, you are asked to save the current default settings, which is a good idea. Once that's done you're taken to a window displaying the six current System Font settings. The default font is Segoe UI already, so all I had to do was select each one in turn, change its Font Style from "Regular" to "Semibold", and its Size from 9 to 12. Click on "Apply", quit the program, and sign out and then back in to Windows, and it's done. I can now enjoy the same level of legibility in Pyramix under Win10 as I can under Win7.