ASIO Ravenna + Hapi with Windows Server 2012 R2

Pyramix Native users forum
Forum rules
The Merging Technologies team cannot be held responsible for support queries logged on the public forums. If a support query is logged here and only here, it may not be found and dealt with by the appropriate team.
To ensure that your support issue or bug report is dealt with properly and in good time, please use the link to the tech support request form page on the Merging website.
Make sure to let us know what version you are using when you send your mail. THANKS!

ASIO Ravenna + Hapi with Windows Server 2012 R2

Postby robertopisa » Sat Apr 04, 2015 08:28

My Hapi finally arrived and I installed Ravenna ASIO successfully on a Mac OS X.

As for Windows, I am aware that it is suggested to use Windows 7... but I am a CS and wanted to experiment with Windows Server 2012 R2 since it is more stable and efficient IMHO.

I partially succeeded. After installing the ASIO driver 64 bits, I had a "DNSServiceBrowse" error when running MTdiscovery, which has been fixed by subsequently extracting with 7zip (and clearly running) the file Bonjour64.msi from the iTunes installer (itunes6464setup.exe) for Windows. So this is the current situation:

  • MergingRavennaASIOPanel apparently works and connects to the Hapi through the local adapter (NIC).
  • MTdiscovery finds the Hapi and clicking over it, open the Web browser with the Hapi menu etc...
  • RavennaEasyConnect finds the Hapi on the right-hand column
Unfortunately, the ASIO driver does not appear in MTdiscovery and hence on the left-hand column of RavennaEasyConnect, even if MergingRavennaASIOPanel is apparently giving no errors.

I suspect that I should add some roles and features in "Server Manager" for Window Server 2012 R2. Any hint is appreciated. Thanks a lot.

Kind regards
Roberto
robertopisa
 
Posts: 16
Joined: Tue Feb 24, 2015 20:38

Re: ASIO Ravenna + Hapi with Windows Server 2012 R2

Postby Graemme » Sun Apr 05, 2015 07:53

Hi Roberto,

It's not clear from your message whether or not you were running an ASIO-capable application at the time you didn't see an entry for it in the Ravenna Easy-Connect panel. You will only see ASIO-enabled device entries in the MT Discovery window and the Ravenna E-C panel when they are actually running.

Regards,

Graemme
Graemme Brown
Zen Mastering
1460 Wild Rose Drive
Gabriola Island, BC
Canada V0R 1X5
+1.604.874.9096

"A Horus, A Horus; My Kingdom for a Horus!"
User avatar
Graemme
 
Posts: 2195
Joined: Wed May 15, 2002 22:18
Location: Vancouver, BC, Canada

Re: ASIO Ravenna + Hapi with Windows Server 2012 R2

Postby robertopisa » Sun Apr 05, 2015 09:52

I installed Windows 7 and got the same situation. This means that I probably succeeded in installing the drivers also on Windows 2012 R2.
robertopisa
 
Posts: 16
Joined: Tue Feb 24, 2015 20:38

Re: ASIO Ravenna + Hapi with Windows Server 2012 R2

Postby robertopisa » Sun Apr 05, 2015 09:56

Thanks Graemme for answering. I would like to use Jriver with Hapi. What's the next step in using Jriver for example? If I choose Merging Asio as audio driver in Jriver, then playing it complains that the audio driver does not support the format. So I need to attach Jriver to ASIO in some way... ASIO bridge complains that a DLL file is missing: there is a web page on the MT site on Jriver but no instructions on how to attach Jriver to Hapi...

Cheers
-Roberto

Graemme wrote:Hi Roberto,

It's not clear from your message whether or not you were running an ASIO-capable application at the time you didn't see an entry for it in the Ravenna Easy-Connect panel. You will only see ASIO-enabled device entries in the MT Discovery window and the Ravenna E-C panel when they are actually running.

Regards,

Graemme
Last edited by robertopisa on Mon Apr 06, 2015 10:10, edited 1 time in total.
robertopisa
 
Posts: 16
Joined: Tue Feb 24, 2015 20:38

Re: ASIO Ravenna + Hapi with Windows Server 2012 R2

Postby Graemme » Mon Apr 06, 2015 10:05

I have JRiver running with a Horus. You will likely have to play around with the settings in JRiver's audio control section to configure the interface between your Hapi and the software. it's not very intuitive!

In JRiver, choose Ravenna ASIO as the driver: No need for the ASIO Bridge, as that is not useful for your setup. I sometimes see those 'format not supported' messages. Often, I just clear the message and start playback again and all is well.

Frankly, there is still some work to be done by both Merging and JRiver to make this combination work together easily and reliably. (At least that is my experience..I would love to hear from other who have it working 'properly', including details of how it was made to be that way!)

Graemme
Graemme Brown
Zen Mastering
1460 Wild Rose Drive
Gabriola Island, BC
Canada V0R 1X5
+1.604.874.9096

"A Horus, A Horus; My Kingdom for a Horus!"
User avatar
Graemme
 
Posts: 2195
Joined: Wed May 15, 2002 22:18
Location: Vancouver, BC, Canada

Re: ASIO Ravenna + Hapi with Windows Server 2012 R2

Postby robertopisa » Mon Apr 06, 2015 10:19

Thanks Graemme, I did it but unfortunately it does not appear ASIO on the left-hand column of EasyConnect. I also see 'format not supported' but cannot play even if I clear the message. I wrote the MT staff, also because I would like to write a mini-tutorial on how to setup and optimise Jriver for Hapi, as it is a great opportunity. I really love this DAC.

Graemme wrote:I have JRiver running with a Horus. You will likely have to play around with the settings in JRiver's audio control section to configure the interface between your Hapi and the software. it's not very intuitive!

In JRiver, choose Ravenna ASIO as the driver: No need for the ASIO Bridge, as that is not useful for your setup. I sometimes see those 'format not supported' messages. Often, I just clear the message and start playback again and all is well.

Frankly, there is still some work to be done by both Merging and JRiver to make this combination work together easily and reliably. (At least that is my experience..I would love to hear from other who have it working 'properly', including details of how it was made to be that way!)

Graemme
robertopisa
 
Posts: 16
Joined: Tue Feb 24, 2015 20:38

Re: ASIO Ravenna + Hapi with Windows Server 2012 R2

Postby robertopisa » Tue Apr 07, 2015 22:37

A couple of snapshots of what is going on in Windows 7.

Image

Image
robertopisa
 
Posts: 16
Joined: Tue Feb 24, 2015 20:38

Re: ASIO Ravenna + Hapi with Windows Server 2012 R2

Postby Graemme » Wed Apr 08, 2015 09:56

As I said before: Even though JRiver often throws up the 'format not supported' message on the first attempt at playback, try it again...works the same way every time for me.

You aren't likely to see anything in the Ravenna ASIO panel's 'status' area (or Ravenna Easy Connect) until the first successful playback begins. Once playback happens, you can then connect your 'DA-1' in the Easy-Connect panel.

[EDIT] You need to turn 'Bitstreaming' on in JRiver for DSD usage with Hapi / Horus.

Graemme
Graemme Brown
Zen Mastering
1460 Wild Rose Drive
Gabriola Island, BC
Canada V0R 1X5
+1.604.874.9096

"A Horus, A Horus; My Kingdom for a Horus!"
User avatar
Graemme
 
Posts: 2195
Joined: Wed May 15, 2002 22:18
Location: Vancouver, BC, Canada

Re: ASIO Ravenna + Hapi with Windows Server 2012 R2

Postby robertopisa » Wed Apr 08, 2015 11:53

Thanks Graemme for the suggestions, but I already tried what you suggest and also what my dealer suggests. The first snapshot shows that I tried many times with JRiver and it does not work (and I set also bitstreaming). The second snapshot shows that HQPlayer goes slightly better in that it allows me to connect DA-1 through EasyConnect but there is a protocol error (see bottom right in the EC window). I have a brand-new fanless PC and the latest version of software with the most recent updates, maybe this is the issue. My dealer told me that new drivers are coming for Prolight + Sound 2015.
robertopisa
 
Posts: 16
Joined: Tue Feb 24, 2015 20:38

Re: ASIO Ravenna + Hapi with Windows Server 2012 R2

Postby Graemme » Thu Apr 09, 2015 06:59

Well, all I can tell you is that 'it works here...'

But just saying that you have the 'latest' software, etc. isn't as helpful as telling us the exact versions you are using, including build numbers. And which version of JRiver?

Graemme
Graemme Brown
Zen Mastering
1460 Wild Rose Drive
Gabriola Island, BC
Canada V0R 1X5
+1.604.874.9096

"A Horus, A Horus; My Kingdom for a Horus!"
User avatar
Graemme
 
Posts: 2195
Joined: Wed May 15, 2002 22:18
Location: Vancouver, BC, Canada

Re: ASIO Ravenna + Hapi with Windows Server 2012 R2

Postby robertopisa » Thu Apr 09, 2015 11:58

It works now! I spent an interesting night before going to work today :)

I could not make it work on Win 7 as it was no more a clean installation. So I decided to erase everything and install again Windows Server 2012 R2 from scratch and with renewed interest.

Initially the setup was not working on Windows Server 2012 R2, but having received the precise instructions from David, I have been able to trace the culprit (as a friend suggested): it was a missing PCI driver on the motherboard that was probably not crucial for normal tasks but showed to be so for ASIO Ravenna. I cannot yet say that it is 100% functional as I need some more testing, but I am quite confident. This week I spent most of my time on this issue... back to life :)

If anyone is interested, I can write my notes here to help people to replicate my installation. I hope to have written notes for all the steps I made so that I can make a small tutorial. Windows Server 2012 R2 is very stable (standard core version with GUI) and network oriented and, IMHO, the ideal setup for Ravenna and Hapi.

It works with Jriver MC20, HQPlayer, Winyl. I will test also Foobar. I cannot test Pyramix or Ovation unless MT borrows me a copy but they probably could do this much better by themselves.

Cheers
Roberto

P,S. I can probably make it work on Win 7 as well, but I am not interested at this point.
robertopisa
 
Posts: 16
Joined: Tue Feb 24, 2015 20:38

Re: ASIO Ravenna + Hapi with Windows Server 2012 R2

Postby robertopisa » Sat Apr 11, 2015 00:00

I installed Wavelab Le 7, and it works with Native ASIO Merging. Also VB ASIO Bridge works, so any app can potentially work using the latter as a sound card.
-R
robertopisa
 
Posts: 16
Joined: Tue Feb 24, 2015 20:38

Re: ASIO Ravenna + Hapi with Windows Server 2012 R2

Postby buggyboy » Mon Dec 19, 2016 19:37

robertopisa wrote:It works now! I spent an interesting night before going to work today :)

Initially the setup was not working on Windows Server 2012 R2, but having received the precise instructions from David, I have been able to trace the culprit (as a friend suggested): it was a missing PCI driver on the motherboard that was probably not crucial for normal tasks but showed to be so for ASIO Ravenna. I cannot yet say that it is 100% functional as I need some more testing,

THANK YOU Roberto!!

I cannot say how much time I spent trying to fix this kind of problem, and on several installs, without knowing why it sometimes worked (and most times, didn't work, of course). I'll try this on my failed attempt at upgrading Win7 to Win10

robertopisa wrote:but I am quite confident. This week I spent most of my time on this issue... back to life :)
If anyone is interested, I can write my notes here to help people to replicate my installation. I hope to have written notes for all the steps I made so that I can make a small tutorial. Windows Server 2012 R2 is very stable (standard core version with GUI) and network oriented and, IMHO, the ideal setup for Ravenna and Hapi.
.
I'm definitely interested about that, and about any tips or tricks that you may have to optimize such a system. I saw that you posted some network optimization that I'm trying right now viewtopic.php?f=54&t=11418&p=36915#p36915 It's working great, thanks for that too :)
buggyboy
 
Posts: 7
Joined: Sat Dec 20, 2014 10:31

Re: ASIO Ravenna + Hapi with Windows Server 2012 R2

Postby buggyboy » Tue Dec 20, 2016 11:31

Well, I've been a little too optimistic. Turns out my Win10 X64 Pro has all drivers installed (UAC down and firewall off, of course) and still, I cannot get a player like foobar to use the Ravenna ASIO driver.

If anyone has another idea, I'd be very interested. Solution : viewtopic.php?f=14&t=12002&p=36993#p36993
buggyboy
 
Posts: 7
Joined: Sat Dec 20, 2014 10:31


Return to Pyramix Native

Who is online

Users browsing this forum: No registered users and 4 guests