Project Folder Lock Issue

Welcome to the Pyramix MassCore discussion forum.
Forum rules
The Merging Technologies team cannot be held responsible for support queries logged on the public forums. If a support query is logged here and only here, it may not be found and dealt with by the appropriate team.
To ensure that your support issue or bug report is dealt with properly and in good time, please use the link to the tech support request form page on the Merging website.
Make sure to let us know what version you are using when you send your mail. THANKS!
Posts: 1
Joined: Sat Apr 19, 2014 02:28

Project Folder Lock Issue

Postby ATG » Wed Apr 30, 2014 14:45

Hi Everyone,

We have an issue that we cant seem to resolve regarding releasing a project folder on close and I am hoping that someone knows the setting(s) we might be overlooking. Our environment consists of 2 Pyramix 7 64 bit systems (note we have also tried 32 Bit windows with same results). The workflow we use is:

1) We open a project on Machine A and perform necessary work on it.
2) When we have completed work on Machine A, the project file is closed (we do not exit pyramix but just close the project)
3) We try and open the project on Machine B. When we open it on Machine B, the project opens fine, plays fine and records fine
4) If we try and do anything on Machine A while the project is being manipulated on Machine B, we lose control of Pyramix on Machine A. Once the playback/recording/etc is complete on Machine B, we resume functionality on Machine A.

We have run a number of tests to determine what the issue is, and have found one consistent issue. When Machine A closes the project, it releases all of the files, BUT does not release the folder itself. If we go in and kill the open handle on that folder, we do not experience the issue, but without manually killing the open handle, we experience the issue.

We have tried this against multiple storage devices (2 x NAS and 1 x Windows Server) and they all do the same thing. Below is a screenshot of the open folder handle which we are seeing and have to kill manually to get this to work:


Any thoughts or solutions would be GREATLY appreciated!