Ubuntu 18 libcurl issue

https://www.merging.com/products/alsa_r ... s67_driver
Forum rules
The Merging Technologies team cannot be held responsible for support queries logged on the public forums. If a support query is logged here and only here, it may not be found and dealt with by the appropriate team.
If you need assistance please contact tech support.
florian
Posts: 79
Joined: Wed May 29, 2002 10:02
Location: Lausanne Switzerland
Contact:

Ubuntu 18 libcurl issue

Postby florian » Mon Mar 04, 2019 10:36

The Butler is dynamically linked to libcurl3. By default Ubuntu 18 installs the version 4 of libcurl.
Here is a way to install libcurl3 on Ubuntu 18:

Code: Select all

# Install libgconf-2-4 with apt-get:
sudo apt-get install libgconf-2-4
# Then add a mirror to the list in /etc/apt/sources.list, E.g
deb http://security.ubuntu.com/ubuntu xenial-security main
# And finally install libcurl3
sudo apt-get install libcurl3


We will work on a more elegant solution soon.
Thanks for your understanding.

PhilippeBekaert
Posts: 2
Joined: Fri May 03, 2019 10:04

Re: Ubuntu 18 libcurl issue

Postby PhilippeBekaert » Fri May 03, 2019 11:24

No luck on ubuntu (studio) 18.10. Still getting

~/ravenna-alsa-lkm/Butler> apt-get install libcurl3
Reading package lists... Done
Building dependency tree
Reading state information... Done
Package libcurl3 is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source
However the following packages replace it:
libcurl4:i386 libcurl4

E: Package 'libcurl3' has no installation candidate


Any suggestions, someone?

Thanks and best,

Philippe.

PhilippeBekaert
Posts: 2
Joined: Fri May 03, 2019 10:04

Re: Ubuntu 18 libcurl issue

Postby PhilippeBekaert » Fri May 03, 2019 11:36

Solved: add the deb line via Favorites -> Settings -> Software & Updates -> Other Software Add button
Just adding the line to /etc/apt/sources-list was not enough. Repository list needs to be reloaded.
Thanks & best,

Philippe.