Page 1 of 1

EUCON not working properly - help!

PostPosted: Thu Nov 05, 2015 17:05
by kwithnail
When connecting an Avid Artist Transport (that works well with other software on the PC), I find Pyramix can't connect to it properly. Key commands work, but EUCON commands don't.
The Transport is added as an OASIS then EUCON device, just as in Avid and Merging's respective manuals, but no luck at all. I've also tried the W7x64 fix that Avid supply for systems with dual Ethernet ports. I have the OASIS Economy key enabled.
Anyone else have this experience? I tried the threads below and google, but have had no luck with either.

Re: EUCON not working properly - help!

PostPosted: Fri Nov 06, 2015 04:33
by a.stinson
Contact Merging, there is a small registry fix for this- I had the same issues on a few machines with this setup.

I'm not sure why this is not documented further as it seems to be a know issue. Once patched it works perfectly.

Re: EUCON not working properly - help!

PostPosted: Mon Nov 09, 2015 14:19
by kwithnail
Thank you - have done so. I'll post the solution here if it works.

Re: EUCON not working properly - help!

PostPosted: Wed Nov 11, 2015 04:38
by phaseboy
This has happened to me a few times when I build a new machine. The .dll is not registered correctly and you need to do it manually. The dll you want to look for is called "MTOASISTPortEucon.dll" It is in /Program Files/Common Files/Merging Technologies/Controllers.

Best Regards,


Re: EUCON not working properly - help!

PostPosted: Wed Nov 11, 2015 14:56
by kwithnail
The fix is as follows:

"Assumng that Pyramix is installed in its default location, download this zip file: ...
Close Pyramix.
Extract and run the .bat file, you should get a message from Windows telling you that the dll registered successfully.
Restart the computer.
The very first time Eucon is attached to Pyramix, the controller faders may not work (but the other functionalities will).
In that case reboot the system one more time, the faders will then always work."

In my case I had to restart a few more times after that before I found that it had worked. Jog/shuttle are very buggy at the moment but that definitely appears to be on the Avid side, not Pyramix. If I can fix that I'll post here again.
Sincere thanks to David Jacques for helping me with this. He also mentions that Pyramix v10 will not need this registry fix.

Re: EUCON not working properly - help!

PostPosted: Tue Sep 19, 2017 17:06
by Silas
Hello to All,

I'm afraid I'm running into this issue again - AVID Artist Mix communicating with EuControl as expected. But Pyramix will not "see it". We have the Oasis 1st order key and I've tried running the V9RegisterPortEucon package. This just errors saying it can find the specified file. When I look in the specified directory there is a similarly named file - but not exact. And I'm not a fan of monkeys flying the airplane so I haven't tried registering that new filename.dll.

MassCore V10.1
Window 7 64-bit
Latest Eucon and ArtistMix firmware.

Any ideas?

Thanks in advance,

Re: EUCON not working properly - help!

PostPosted: Tue Sep 19, 2017 18:40
by J.Wajer
Hey Silas,

dont have any advice nor solutions for you, but from your post I can see you are trying to run a V9RegisterPortEucon on MassCore V10.1? Maybe it is that?

Re: EUCON not working properly - help!

PostPosted: Wed Sep 20, 2017 01:02
by Silas
Thanks J Wajer. Yes - confirmed that the V9 package doesn't work. Here is the response from David Jacques (I hope he won't mind this paste):

"Since Pyramix V10.0, Eucon has been renamed to EUCON2, so please see in Pyramix settings > Remote Control > Controller that your Artist is set to OASIS driver, and EUCON2 transport (click on the Properties button next to Driver : OASIS)

In EuControl, please also make sure that in the Workstations tab, your computer is in the “My workstations” list and attached (X sign).

If you have several network adapters, you need an additional step to configure those network adapters, please follow the procedure described on that page : ... ontrollers

The very first time you connect the Artist in Pyramix 10, the faders will not work but all the other controls will (transport for example). Restart your computer, the faders will then always work in Pyramix.

The old V9RegisterPortEucon does not work with Pyramix 10."

So probably pilot error on my part - will try ASAP this week and report back.