EUCON not working properly - help!

3rd Party controllers used with Merging products
Forum rules
The Merging Technologies team cannot be held responsible for support queries logged on the public forums. If a support query is logged here and only here, it may not be found and dealt with by the appropriate team.
To ensure that your support issue or bug report is dealt with properly and in good time, please use the link to the bug reporting form page on the Merging website.
Make sure to let us know what version you are using when you send your mail. THANKS!

EUCON not working properly - help!

Postby kwithnail » Thu Nov 05, 2015 17:05

When connecting an Avid Artist Transport (that works well with other software on the PC), I find Pyramix can't connect to it properly. Key commands work, but EUCON commands don't.
The Transport is added as an OASIS then EUCON device, just as in Avid and Merging's respective manuals, but no luck at all. I've also tried the W7x64 fix that Avid supply for systems with dual Ethernet ports. I have the OASIS Economy key enabled.
Anyone else have this experience? I tried the threads below and google, but have had no luck with either.
Posts: 9
Joined: Thu Jul 02, 2015 18:27

Re: EUCON not working properly - help!

Postby a.stinson » Fri Nov 06, 2015 04:33

Contact Merging, there is a small registry fix for this- I had the same issues on a few machines with this setup.

I'm not sure why this is not documented further as it seems to be a know issue. Once patched it works perfectly.
Posts: 41
Joined: Wed Apr 09, 2008 04:55

Re: EUCON not working properly - help!

Postby kwithnail » Mon Nov 09, 2015 14:19

Thank you - have done so. I'll post the solution here if it works.
Posts: 9
Joined: Thu Jul 02, 2015 18:27

Re: EUCON not working properly - help!

Postby phaseboy » Wed Nov 11, 2015 04:38

This has happened to me a few times when I build a new machine. The .dll is not registered correctly and you need to do it manually. The dll you want to look for is called "MTOASISTPortEucon.dll" It is in /Program Files/Common Files/Merging Technologies/Controllers.

Best Regards,

Mark S. Willsher
(studio: +1-818-284-6136)
User avatar
Posts: 499
Joined: Thu Nov 21, 2002 23:41
Location: San Francisco

Re: EUCON not working properly - help!

Postby kwithnail » Wed Nov 11, 2015 14:56

The fix is as follows:

"Assumng that Pyramix is installed in its default location, download this zip file: ...
Close Pyramix.
Extract and run the .bat file, you should get a message from Windows telling you that the dll registered successfully.
Restart the computer.
The very first time Eucon is attached to Pyramix, the controller faders may not work (but the other functionalities will).
In that case reboot the system one more time, the faders will then always work."

In my case I had to restart a few more times after that before I found that it had worked. Jog/shuttle are very buggy at the moment but that definitely appears to be on the Avid side, not Pyramix. If I can fix that I'll post here again.
Sincere thanks to David Jacques for helping me with this. He also mentions that Pyramix v10 will not need this registry fix.
Posts: 9
Joined: Thu Jul 02, 2015 18:27

Return to 3rd Party controllers

Who is online

Users browsing this forum: No registered users and 1 guest