Pyramix bug - shortcut bindings suddenly not recognised

Welcome to the Pyramix MassCore discussion forum.
Forum rules
The Merging Technologies team cannot be held responsible for support queries logged on the public forums. If a support query is logged here and only here, it may not be found and dealt with by the appropriate team.
To ensure that your support issue or bug report is dealt with properly and in good time, please use the link to the tech support request form page on the Merging website.
Make sure to let us know what version you are using when you send your mail. THANKS!
Posts: 54
Joined: Wed Feb 04, 2009 19:26

Pyramix bug - shortcut bindings suddenly not recognised

Postby AndyR » Thu Aug 24, 2017 18:44

Hi there,

I'm seeing some weird behaviour with keyboard shortcuts, two have just stopped working for me in the last hour, having been going for the last 8 straight.

I had ' assigned to clips : deselect all, and made a selection, hit ' and nothing happened. checked the shortcut settings and it didn't show up the usual 'currently assigned to :' dialogue and had just disappeared from the assigned keys for that entry. Rebound it and worked immediately

I had \ assigned to cursor and marks : nudge cursor to next marker, and had tabbed back between marks and then forward immediately and the shortcut stopped registering.
Checked in the shortcuts settings again, didn't trigger the 'currently assigned to:' dialogue. However, it was listed under Assigned Keys in the appropriate entry. Removed it and reassigned it, worked perfectly again.

Really odd.

I use both these shortcuts a lot - so I'm confident they were bound properly and functional very shortly beforehand.

Any ideas?!


Win 11 64bit, pmx11.04 build 3513 29.06.2017
also running; acrobat reader, microsoft word 2016
windows defender - no 3rd party AntiV

User avatar
Posts: 1323
Joined: Sun Feb 11, 2007 19:55
Location: Toronto, Ontario, Canada

Re: Pyramix bug - shortcut bindings suddenly not recognised

Postby fl » Fri Aug 25, 2017 13:59

Off the top of my head, I wonder if somehow your Keyboard Shortcuts Preset got changed inadvertently. Pyramix comes with several Keyboard Shortcut Presets - Pro Tools, Pro Tools TDM, Pyramix 3.0, Sadie, etc. - which all contain different key-to-action links. Have you created one with your own custom Shortcuts? When and if you lose your shortcuts once again, what happens if you just recall your own Keyboard Shortcuts Preset in the Keyboard Shortcuts Editor (perhaps switching to another one briefly, and then switching back)?

The other thing which occurred to me is that you may have assigned a Keyboard shortcut, to a command which already has one hard-coded in Pyramix. I've been using CTRL+D to Deselect All Clips for years, but I always thought it was coded that way by Merging, not by me (unless perhaps I've just forgotten doing it myself). Perhaps there is conflict somewhere (although I can't think of one involving ' or \).

The use of single key shortcuts (no Modifier key like Shift, Alt or Ctrl) can be problematic, especially if you create a Shortcut using a key from the left side of the keyboard (f, r, d, and a few others), since some of those keys are used as mouse action modifiers, but both ' and \ should be fine.

If you've been typing in notes in the Notes Tab, Pyramix will understand that you want the keyboard as a text entering device, and will shift focus away from the Timeline, to allow you to type normally. This can happen with any operation where you are intentionally entering text, not calling commands by shortcut. When you go back to the Timeline without mouse clicking anywhere, Pyramix will think that you're still writing text, and your keyboard shortcut won't work (but rather, you were entering in a bunch of 's or \s in the Notes tab or wherever, as you pound away in frustration - particularly frustrating if you had any text highlighted in the Notes, which is now replaced with \\\\\\\ or '''''''). The next time you "lose" your shortcuts, try a mouse click on a Track Header, and then try again - it could have been just a simple case of Pyramix being confused as to your intention.
Frank Lockwood, Toronto, ON, Canada
• Pyramix Native
• Mac Mini 6.2 (Quadcore i7) - Bootcamp 5.1.5621 - Win7 Pro SP1 64
• HP 7100 Mini-tower - Win10 Pro 64 1809
• RME Fireface 800 ASIO driver 3.125 or ASIO4All 2.13

Posts: 54
Joined: Wed Feb 04, 2009 19:26

Re: Pyramix bug - shortcut bindings suddenly not recognised

Postby AndyR » Fri Sep 01, 2017 16:07

Hi Frank - thanks for the suggestions,

I loaded a custom shortcut preset that I've used for years. Loading a different table, and then the original fixed it, as did unasigning and reassigning the two shortcuts.

I don't ever use the notes tab in pmx, i don't even have it open so it's not included in the tabs list.

Good idea though.