Native crash when 'opening effects state'

Welcome to the Pyramix MassCore discussion forum.
Forum rules
The Merging Technologies team cannot be held responsible for support queries logged on the public forums. If a support query is logged here and only here, it may not be found and dealt with by the appropriate team.
To ensure that your support issue or bug report is dealt with properly and in good time, please use the link to the tech support request form page on the Merging website.
Make sure to let us know what version you are using when you send your mail. THANKS!

Native crash when 'opening effects state'

Postby joelgordon » Thu Jun 29, 2017 17:15

Wondering if anyone has a workaround (even a solution !) for this first ever (for me) problem.

I'm trying to open a particular project on my laptop (running pyramix 64 bit native v9) and it crashes Pyramix when it gets to the stage of 'loading effects state'. The project was transfered from my studio (Mass Core v9 64 bit) and is much like hundreds of my other projects ---- 24 chnls, some automation, a few strip tools, altiverb and Syrah. Other similar projects work fine. I'm on the road, far from the studio and need to work on this project so any wisdom would be appreciated.

Thanks
joelgordon
 
Posts: 10
Joined: Sat Apr 23, 2005 21:38
Location: Boston USA

Re: Native crash when 'opening effects state'

Postby fl » Fri Jun 30, 2017 20:10

Is it possible that one of your plug-ins has become corrupted? You might want to try re-installing Altiverb and Syrah, or just start Pyramix without opening your Project, and do a "Force Re-scan" of your VST plug-ins.

Have you applied any Microsoft updates to your system recently? MS has been pumping our some problematic updates in the last year or two...
Frank Lockwood, Toronto, ON, Canada
http://LockwoodARS.com
Native 11.0.5/Native Music 9.1.10
Win7 Pro SP1 64/32
Bootcamp 5.1.5621/4.0.4033
Mac Mini 6.2 (Quadcore i7)/MacBook Pro 3.1 (Core2Duo)
RME Fireface 800, driver version 3.122
User avatar
fl
 
Posts: 1195
Joined: Sun Feb 11, 2007 19:55
Location: Toronto, Ontario, Canada

Re: Native crash when 'opening effects state'

Postby Jesse.Lewis » Thu Jul 20, 2017 04:08

This is unfortunately common - I have struggled with Flux VSTs crashing the mixer for years.

Try updating your Flux plugs to the latest version.

Cheers,
Jesse
Jesse.Lewis
 
Posts: 55
Joined: Fri Jan 22, 2010 18:58

Re: Native crash when 'opening effects state'

Postby joelgordon » Thu Jul 20, 2017 05:37

Frank and Jesse,

Thanks to both of you. I tried rescanning and then even removing the flux plugin (Syrah) but no luck. I've actually had this issue once before on a 2 channel project with no plug ins at all but Eqx. I brought it back home to the studio and it ran fine. I can't even blame Microsoft as I haven't installed any recent updates.

Thanks again.

Joel
joelgordon
 
Posts: 10
Joined: Sat Apr 23, 2005 21:38
Location: Boston USA

Re: Native crash when 'opening effects state'

Postby Jesse.Lewis » Thu Jul 20, 2017 13:44

I often have found the MassCore version ran fine, but it crashed in Native (or visa versa!). Can you test that?

The Merging guys have been very helpful to me in getting the unplayable to play and unopenable to open... :wink: They were able to identify the specific plug causing the crash.

Jesse
Jesse.Lewis
 
Posts: 55
Joined: Fri Jan 22, 2010 18:58

Re: Native crash when 'opening effects state'

Postby fl » Thu Jul 20, 2017 15:19

In the past couple of weeks, I've encountered this issue, especially when opening old projects. It seems that anything that could affect a VST plugin from instantiating itself will cause Pyramix to crash - for example, when opening an IR Reverb which cannot find the particular IR that was in use when the Project was last saved. Even when the plugin offers to either allow you to search for the missing element, or to cancel opening, the damage has been done, Pyramix locks up and has to be Force Quit.

It would be great if there was some way to open a project without fully activating any VSTs - similar to booting up Windows in "Safe" mode. Then at least you could modify the project to salvage what you can.
Frank Lockwood, Toronto, ON, Canada
http://LockwoodARS.com
Native 11.0.5/Native Music 9.1.10
Win7 Pro SP1 64/32
Bootcamp 5.1.5621/4.0.4033
Mac Mini 6.2 (Quadcore i7)/MacBook Pro 3.1 (Core2Duo)
RME Fireface 800, driver version 3.122
User avatar
fl
 
Posts: 1195
Joined: Sun Feb 11, 2007 19:55
Location: Toronto, Ontario, Canada

Re: Native crash when 'opening effects state'

Postby joelgordon » Thu Jul 20, 2017 15:57

Yes, when I got back to the studio it ran fine in Masscore and I finished the project there. Dennis at Merging did send me back a new version which I haven't tested out yet (it came after the project was done) but I will check it out at some point. What's weird is that the project - once corrupted - was unable to start up on the laptop even with all plug ins removed !
What's also weird (but probably common) is that other projects - newer as well as older - using the same plug ins open just fine on either system. Sometimes I miss my editing block and razor blade
joelgordon
 
Posts: 10
Joined: Sat Apr 23, 2005 21:38
Location: Boston USA

Re: Native crash when 'opening effects state'

Postby Jesse.Lewis » Fri Jul 21, 2017 04:57

I'm running another project now which locks up in Native, but runs fine in Masscore - but related to a media issue. Project will not open in Native... Native has some problems which MassCore somehow overcomes.
Jesse.Lewis
 
Posts: 55
Joined: Fri Jan 22, 2010 18:58


Return to Pyramix General

Who is online

Users browsing this forum: Bing [Bot] and 13 guests

cron