Non latching talk to all

Welcome to the Pyramix MassCore discussion forum.
Forum rules
The Merging Technologies team cannot be held responsible for support queries logged on the public forums. If a support query is logged here and only here, it may not be found and dealt with by the appropriate team.
To ensure that your support issue or bug report is dealt with properly and in good time, please use the link to the tech support request form page on the Merging website.
Make sure to let us know what version you are using when you send your mail. THANKS!

Non latching talk to all

Postby mpdonahue » Mon Mar 27, 2017 22:04

Is there any way to get "Talk to All" in the talkback panel to be non-latching?
I've built a little producers box with an electret mic and talkback amplifier that runs on Phantom Power that includes an integrated USB external controller. The whole point of this exercise is to build a system that I can use with a Hapi and a laptop without carrying around a bunch of external boxes.
When I map the control to the "Talk to All" feature, it is a latching talkback. I work with a bunch of producers that would self destruct if they had to deal with latching talk back. Is there any way to defeat the talkback latching all together?

All the best,
Mark Donahue
*********************
Mark Donahue
Soundmirror, Inc.
Boston, MA
mark@soundmirror.com
www.soundmirror.com
*********************
User avatar
mpdonahue
 
Posts: 395
Joined: Fri Jan 16, 2004 03:20
Location: Boston, MA

Re: Non latching talk to all

Postby fl » Tue Mar 28, 2017 13:36

Mark,

All the latching controls are set in the Monitor > Talkback window - the same place where you set up the TB input and output connections. The latching controls are three little boxes at the top centre of the window - disable them all.

It's possible that you were referring to the latching of the TB mic control itself in the main "Monitor!" window, in which case I believe that if you press and hold whatever controller you use, it will behave as a momentary switch, whereas if you just pop it once, it will stay on.

An alternative would be to simply have TB enabled in Pyramix's Monitor! window all the time, and control whether or not the mic is actually "live" some other way - I have one of those Shure 522 mics which has a "push to talk" button. On your Producer's box, you may have to install a "momentary" switch to en/disable the built-in mic.

For a while I was using a Logidy UMI3 MIDI foot-switch controller - http://logidy.com/?pid=1 - which connects via USB, and could be programed to send specific MIDI commands for each of its three switches. The Logidy has a provision to issue one command when the switch is depressed, and another when it's released. After setting up Pyramix's External Controllers Settings to map the chosen MIDI commands to the appropriate operations, I was able to enable/disable the TB mic in the "Monitor!" window, with my foot, using the other two switches for "Record/Stop" and "Play/Stop" respectively. Very handy (well, footy) when you're busy writing notes.

For those who might be interested, I put together a little tutorial for setting up Talkback a while back, and it's available at https://www.dropbox.com/sh/ct9p8m6r31wm ... CoxDa?dl=0

If you're running any kind of playback/foldback (so that you can play portions of recorded material over your TB speaker), you can enable/disable that separately in the Main Monitor window using the little (blue when enabled) boxes on the lower left. By setting up a separate Mix Bus for foldback, and then using the "Repro" button on the bus, you can have playback available, yet it will never be live, and therefore prone to feedback, when you're Recording or just Stopped.

The automatic latching seems like it would be a good idea, but most people I work with hate it.
Frank Lockwood, Toronto, ON, Canada
http://LockwoodARS.com
Native 11.0.5/Native Music 9.1.10
Win7 Pro SP1 64/32
Bootcamp 5.1.5621/4.0.4033
Mac Mini 6.2 (Quadcore i7)/MacBook Pro 3.1 (Core2Duo)
RME Fireface 800, driver version 3.122
User avatar
fl
 
Posts: 1198
Joined: Sun Feb 11, 2007 19:55
Location: Toronto, Ontario, Canada

Re: Non latching talk to all

Postby Thierry04 » Tue Apr 25, 2017 06:46

fl wrote:Mark,

All the latching controls are set in the Monitor > Talkback window - the same place where you set up the TB input and output connections. The latching controls are three little boxes at the top centre of the window - disable them all.

It's possible that you were referring to the latching of the TB mic control itself in the main "Monitor!" window, in which case I believe that if you press and hold whatever controller you use, it will behave as a momentary switch, whereas if you just pop it once, it will stay on.

An alternative would be to simply have TB enabled in Pyramix's Monitor! window all the time, and control whether or not the mic is actually "live" some other way - I have one of those Shure 522 mics which has a "push to talk" button. On your Producer's box, you may have to install a "momentary" switch to en/disable the built-in mic.

For a while I was using a Logidy UMI3 MIDI foot-switch controller - paris airports transfershttp://logidy.com/?pid=1 - which connects via USB, and could be programed to send specific MIDI commands for each of its three switches. The Logidy has a provision to issue one command when the switch is depressed, and another when it's released. After setting up Pyramix's External Controllers Settings to map the chosen MIDI commands to the appropriate operations, I was able to enable/disable the TB mic in the "Monitor!" window, with my foot, using the other two switches for "Record/Stop" and "Play/Stop" respectively. Very handy (well, footy) when you're busy writing notes.

For those who might be interested, I put together a little tutorial for setting up Talkback a while back, and it's available at https://www.dropbox.com/sh/ct9p8m6r31wm ... CoxDa?dl=0

If you're running any kind of playback/foldback (so that you can play portions of recorded material over your TB speaker), you can enable/disable that separately in the Main Monitor window using the little (blue when enabled) boxes on the lower left. By setting up a separate Mix Bus for foldback, and then using the "Repro" button on the bus, you can have playback available, yet it will never be live, and therefore prone to feedback, when you're Recording or just Stopped.

The automatic latching seems like it would be a good idea, but most people I work with hate it.

Hello, thank you for the links that you shared, it's so helpful
Thierry04
 
Posts: 1
Joined: Tue Apr 25, 2017 06:42

Re: Non latching talk to all

Postby per » Sun Jun 11, 2017 15:13

Hi,

In the Keyboard shortcuts editor, you can make two commands for the Talk To All key: One triggered by Key Down and the other triggered by Key Up. This way, Talkback will only be activated when you hold down the HOME key and is turned off when you release the key.

Per
Sound Processing AB
Sweden
per
 
Posts: 188
Joined: Tue Jun 03, 2003 18:21
Location: Gothenburg, Sweden

Re: Non latching talk to all

Postby mpdonahue » Mon Jun 12, 2017 18:01

per wrote:Hi,

In the Keyboard shortcuts editor, you can make two commands for the Talk To All key: One triggered by Key Down and the other triggered by Key Up. This way, Talkback will only be activated when you hold down the HOME key and is turned off when you release the key.
Per
I don't know which version you're using, but in 10.2, the "talk to all" latches on and can only be reset by the reset button in the monitor panel, to which there is no link in keyboard shortcuts. Pressing on the button or repeating the keystroke does nothing.
The talkback functions can be addressed using GPIO, but spending $500 for a sealevel controller does not make any sense given that we have 12 systems here. We had Maurice Engler from Merging here last week and discussed this issue. We also discussed the possibility of getting the Xkeys controller functionality integrated into PMX. Only time will tell if they fix this stuff. These issues are the thing holding us back from using PMX without some form of control room monitor system.
All the best,
-mark
*********************
Mark Donahue
Soundmirror, Inc.
Boston, MA
mark@soundmirror.com
www.soundmirror.com
*********************
User avatar
mpdonahue
 
Posts: 395
Joined: Fri Jan 16, 2004 03:20
Location: Boston, MA

Re: Non latching talk to all

Postby per » Tue Jun 13, 2017 18:51

Hello Mark,

I have version 10.2 Native on one machine. I'm pretty sure pressing HOME one more time will turn off "Talk to All". I say "I'm pretty sure", because I'm using the key assignment I mentioned and it works fine, so on my computer "Talk to All" is ON as long as I hold down the HOME key and turns off when I release it. I wanted to show you screen prints of the keyboard editor, but I don't know how to do that. Strange things happened when I tried...

However:
In the keyboard command editor, there's a text box [Press new shortcut key] showing which key you have chosen. To the right of that is a check box that says "Key Up", so when this is checked, the command is sent when the key is released. If you look at the Monitor pane, there's probably already an assignment for "Talk to All": the HOME key. Check "Key Up" and place the cursor in the [Press new shortcut key] text box and press the HOME key and acknowledge with the "Assign" button. Now you have two assignments for "Talk to All".

From time to time in the midst of the storm, this command may become "inverted", so that releasing the HOME key turns "Talk to All" ON. If this happens, you can click "Talk to All" with the mouse and then you are in phase again.

Hope this helps!
Per
Sound Processing AB
Sweden
per
 
Posts: 188
Joined: Tue Jun 03, 2003 18:21
Location: Gothenburg, Sweden

Re: Non latching talk to all

Postby fl » Tue Jun 13, 2017 19:17

..., and just to add my two cents..., It doesn't have to be the "Home" key - you can assign this double keyboard shortcut to any key not already in use by Pyramix (such as Q, A, Z, W, S, E, D, C, F, V and H which are used for other operations and therefore cannot be reassigned). My MacBook Pro keyboard doesn't even have a HOME key, so I've assigned the Talk to All toggle to the "\" key over on the right edge.
Frank Lockwood, Toronto, ON, Canada
http://LockwoodARS.com
Native 11.0.5/Native Music 9.1.10
Win7 Pro SP1 64/32
Bootcamp 5.1.5621/4.0.4033
Mac Mini 6.2 (Quadcore i7)/MacBook Pro 3.1 (Core2Duo)
RME Fireface 800, driver version 3.122
User avatar
fl
 
Posts: 1198
Joined: Sun Feb 11, 2007 19:55
Location: Toronto, Ontario, Canada

Re: Non latching talk to all

Postby per » Tue Jun 13, 2017 23:33

I'm not sure whether it was someone in this forum that showed me a really cheap ($15 or so) Chinese USB footswitch that comes with a piece of software that lets you assign any key to be sent as you set your foot on the switch. This is handy if you want to control Talk to All using your foot.

But I guess you could also control e.g. recording: Press the switch to start recording. Release to stop.
For really short recordings :D

Per
Sound Processing AB
Sweden
per
 
Posts: 188
Joined: Tue Jun 03, 2003 18:21
Location: Gothenburg, Sweden

Re: Non latching talk to all

Postby mpdonahue » Wed Jun 14, 2017 17:11

OK, I added the key down/key up and it does reset the "talk to all". However, using my xkeys controller, every 10 or 15 times, it gets stuck on, which is a non starter for us here. In the heat of a symphonic patch session if the talkback got stuck on, the producer's head would explode (Most likely taking me out in the process ;-) It would really be much easier to have the reset button available in the shortcut editor.
Thanks for your help.
All the best,
-mark
*********************
Mark Donahue
Soundmirror, Inc.
Boston, MA
mark@soundmirror.com
www.soundmirror.com
*********************
User avatar
mpdonahue
 
Posts: 395
Joined: Fri Jan 16, 2004 03:20
Location: Boston, MA

Re: Non latching talk to all

Postby per » Wed Jun 14, 2017 17:53

Yes, I wonder why it does that. Maybe this is due to the connection Keyboard - Windows? Perhaps Frank can figure this out :)
As I mentioned, when this happens I just click on the "Talk to All" icon to shut it down.
But I agree it would be useful to have access to the Reset command with a key as well.

Cheers
Per
Sound Processing AB
Sweden
per
 
Posts: 188
Joined: Tue Jun 03, 2003 18:21
Location: Gothenburg, Sweden

Re: Non latching talk to all

Postby fl » Wed Jun 14, 2017 18:13

I heard my name...

Firstly, the pedal that per mentioned might very well have been the Logidy UMI3 Pedal - but it's not $15 - more like $80 USD (at Amazon.com). While it uses a USB connection, it's communicating with MIDI, so using it to control Talkback and other functions (there are three foot-switches) is all done without Keyboard Shortcuts. Mark, this might be a better option for you - at least until Merging provides an easier way to control "Talk to All".
Frank Lockwood, Toronto, ON, Canada
http://LockwoodARS.com
Native 11.0.5/Native Music 9.1.10
Win7 Pro SP1 64/32
Bootcamp 5.1.5621/4.0.4033
Mac Mini 6.2 (Quadcore i7)/MacBook Pro 3.1 (Core2Duo)
RME Fireface 800, driver version 3.122
User avatar
fl
 
Posts: 1198
Joined: Sun Feb 11, 2007 19:55
Location: Toronto, Ontario, Canada

Re: Non latching talk to all

Postby per » Wed Jun 14, 2017 18:26

This is probably a first: Frank, you're mistaken :D
I checked it up and it's this one
http://www.pcsensor.com/pcsensor-foot-s ... witch.html

and the price is $9,50!!

OK, this is not a professional piece of gear, I admit, so I bought 2 to make sure at least one was working :) But it actually works.
And it sends keybord characters via USB just like a normal keyboard. If you buy 80 pedals you can replace the keyboard entirely... :)

Best
Per
Sound Processing AB
Sweden
per
 
Posts: 188
Joined: Tue Jun 03, 2003 18:21
Location: Gothenburg, Sweden

Re: Non latching talk to all

Postby fl » Thu Jun 15, 2017 13:51

I wish I had found this before I spent the $80 way back when, even though the Logidy is a well build piece of gear.

However, it's compelling to think of you tap dancing your way through a session with 80 foot pedals, while maintaining hands free for more important wild gesticulations and sandwich eating...
Frank Lockwood, Toronto, ON, Canada
http://LockwoodARS.com
Native 11.0.5/Native Music 9.1.10
Win7 Pro SP1 64/32
Bootcamp 5.1.5621/4.0.4033
Mac Mini 6.2 (Quadcore i7)/MacBook Pro 3.1 (Core2Duo)
RME Fireface 800, driver version 3.122
User avatar
fl
 
Posts: 1198
Joined: Sun Feb 11, 2007 19:55
Location: Toronto, Ontario, Canada

Re: Non latching talk to all

Postby charlienyc » Thu Jun 15, 2017 19:21

I've had good luck with this pedal also: http://a.co/0ozh0Wc
You'll have to dig around a bit to find the correct software. Once you have that you can assign each of the three pedals to any key.
Cheers
2x MassCore v10.1.4 Win7/64 i5-3450
3x Horus w/3 AD8p, 6 AD8, 1 DA8, 2 DA8p
Native v10.1.4 Win7/64 Pro i7 HP
Native v10.1.4 Win10 Bootcamp Mac Mini i5-4278U 2.6GHz
Native V8.1 Win7/32 Xeon 3520 2.67GHz RME HDSP MADI
Native V8.1 Win7/32 ThinkPad R61
User avatar
charlienyc
 
Posts: 332
Joined: Wed Aug 16, 2006 22:40
Location: chicago, il

Re: Non latching talk to all

Postby mpdonahue » Thu Jun 15, 2017 22:16

I ordered a couple of these USB contact closure devices because I'm building them into my own custom talkback boxes.

http://www.ebay.com/itm/322548204132

The whole talkback box runs on phantom power and can be used with or without the USB control. USB control adds Dim and Mute for the control room speakers as well as clickless talkback. When using it without the USB control, there is always a small click when the button is pressed.
All the best,
-mark
*********************
Mark Donahue
Soundmirror, Inc.
Boston, MA
mark@soundmirror.com
www.soundmirror.com
*********************
User avatar
mpdonahue
 
Posts: 395
Joined: Fri Jan 16, 2004 03:20
Location: Boston, MA


Return to Pyramix General

Who is online

Users browsing this forum: Google [Bot] and 6 guests