Pyramix Native 9.1.10 192 kHz playback issue

Welcome to the Pyramix MassCore discussion forum.
Forum rules
The Merging Technologies team cannot be held responsible for support queries logged on the public forums. If a support query is logged here and only here, it may not be found and dealt with by the appropriate team.
To ensure that your support issue or bug report is dealt with properly and in good time, please use the link to the tech support request form page on the Merging website.
Make sure to let us know what version you are using when you send your mail. THANKS!

Pyramix Native 9.1.10 192 kHz playback issue

Postby Monsieur Z » Sat Feb 11, 2017 21:14

Hello to all,

This my first post here, sadly it is not for saying hello (well not only :wink: ) it is for asking some help.

I have a strange issue, I can't play any 192 kHz files with Pyramix without having crackles and pops. The same files (poly 8 tracks 24/192) played without any trouble in Wave Agent from sound device and I can play the stereo 192 kHz files in RX 5 and foobar via asio without a hassle, so I don't really understand what's what.

Does anyone know what can I do ? Did I miss something ? :?: :?: :?: :?:

Configuration :
Pyramix Native 9.1.10
Windows 7 SP1 32 bits
Antivirus disabled (but AVAST)
Only the time-stretch key.

PC desktop
Quad core i72600 cpu @ 3.4 GHz
3 Gb ram

Rme Hammerfall HDSP linked via one single AES cable to a Cranesong Avocet
Latest driver from RME (4.17)

Any help would be greatly appreciated !

Romain Zémiri
Monsieur Z
 
Posts: 7
Joined: Fri Oct 25, 2013 12:25

Re: Pyramix Native 9.1.10 192 kHz playback issue

Postby Monsieur Z » Sat Feb 11, 2017 21:30

And after creating a new project from scratch... it works now. :| :| :|

I have no idea what went wrong, but I don't have any more time to wonder.

Sorry for the useless thread, If a kind administrator judge that it must be deleted, I have absolutely nothing against that. :wink:

Regards.
Monsieur Z
 
Posts: 7
Joined: Fri Oct 25, 2013 12:25

Re: Pyramix Native 9.1.10 192 kHz playback issue

Postby fl » Sun Feb 12, 2017 15:24

Cracks and pops are usually symptoms of clocking or latency issues with your interface. Did you change any latency settings for the Hammerfall/Cranesong combo between those sessions? Perhaps there was some internal conflict about which device was the clock master, or maybe you were running with insufficient latency.

I was informed by Merging Support a couple of years ago that when using my RME Fireface, I should avoid any latency settings which aren't multiples of 64. Even though other values are offered, Pyramix doesn't like them. Most of the time, I run with the maximum latency value, unless I'm recording where acoustic leakage into my headphones conflicts with the delayed signal.
Frank Lockwood, Toronto, ON, Canada
http://LockwoodARS.com
Native 11.0.5/Native Music 9.1.10
Win7 Pro SP1 64/32
Bootcamp 5.1.5621/4.0.4033
Mac Mini 6.2 (Quadcore i7)/MacBook Pro 3.1 (Core2Duo)
RME Fireface 800, driver version 3.122
User avatar
fl
 
Posts: 1198
Joined: Sun Feb 11, 2007 19:55
Location: Toronto, Ontario, Canada

Re: Pyramix Native 9.1.10 192 kHz playback issue

Postby Monsieur Z » Sun Feb 12, 2017 16:27

Hello fl,

Thanks for your input.
I don't think there is a synchro conflict between the Avocet ad the Hammerfall, there is only one connection from the RME to the avocet, if a synch problem was there I would have it with every program, not just PMX.

Actually, the issue is back and alive again. :evil:
After playing, as you suggested, with the buffer size of the Hammerfall control panel, I managed to make the clicks disapear for a couple of second of smooth playback. But then, the problem gets back.
As you mention, increasing the buffer size makes things worse. I don't have the possibility to choose a non-64 multiple here, so that's covered.
I experimented with the playback look ahead buffer in PMX setting, level 4 seems to be a tiny bit better (still random clicks, but less)
I tried to also enable the realtime SRC to be able to fool the Hammerfall control Panel (or Fool PMX, or both...) and put the project in 96 kHz with a 64 buffer, and it's worth, BUT in 48000 kHz with a 32 buffer, it's better (still not perfect though)
PMX's playback performance tab shows that I have 100Mb/s at the beginning of playback and up to 600 Mb/s transfer rate after a couple of second, which, with a 8 tracks 192 kHz project seems a tad exaggerated...

Is there a workaround this ? Merging IT's ? Somebody ? HELP PLEASE !
Monsieur Z
 
Posts: 7
Joined: Fri Oct 25, 2013 12:25

Re: Pyramix Native 9.1.10 192 kHz playback issue

Postby fl » Sun Feb 12, 2017 18:26

Monsieur Z wrote:I don't think there is a synchro conflict between the Avocet ad the Hammerfall, there is only one connection from the RME to the avocet, if a synch problem was there I would have it with every program, not just PMX.

In the Pyramix Settings > Hardware > Formats&Sync page, on the right side under Audio Synchronization, what is shown in the Master Sync field? The Source Field? On my machine, there is only one option for both fields, so there's no choice. On your system, I would imagine that the Hammerfall automatically slaves to the Avocet, but I'm curious as to what is shown in the Pyramix Settings window.
(Side note: Accessing the Hammerfall's Control Panel is best done through this Settings page when Pyramix is running, so that changes made there are immediately recognized by Pyramix. Calling the settings from the Hammerfall's Notification Area icon can sometimes cause some instability.)

As you mention, increasing the buffer size makes things worse.

Worse? That's strange - a larger latency buffer should reduce any clicking and popping, not make it worse. Are you running any processor intensive plug-ins? Any concurrent programs or operations? You've mentioned that you've disabled Avast, but could there be any other process running that could affect your computer's performance? A tool like LatencyMon - http://www.resplendence.com/latencymon - could help track down likely culprits.

I experimented with the playback look ahead buffer in PMX setting, level 4 seems to be a tiny bit better (still random clicks, but less)

On that same page in the Settings, have you changed the Record Block Size to anything but 64 KB?

PMX's playback performance tab shows that I have 100Mb/s at the beginning of playback and up to 600 Mb/s transfer rate after a couple of second, which, with a 8 tracks 192 kHz project seems a tad exaggerated...

I'm afraid I become a little bewildered when looking at that window - when playing back a six track, 96 kHz. project for the first time, my Transfer Rates are usually quite low, but if I stop playback and then immediately start again, the rates shown are much higher and can be all over the place - ramping up, down or just remaining so high that the panel becomes a solid green band. If I switch to a different project, or even just a different playlist within the same project, the first playback will show low Transfer rates, but any subsequent playback shows higher, although usually it's only for a short time, and then things ramp downward. At all times, playback proceeds without any clicks or pops, even if I reduce my Fireface's latency to 128 or even 96 samples, even when the displayed Transfer Rates exceed 2000 Mb/sec. Perhaps someone else has greater insight as to just what is being shown in that window.
Frank Lockwood, Toronto, ON, Canada
http://LockwoodARS.com
Native 11.0.5/Native Music 9.1.10
Win7 Pro SP1 64/32
Bootcamp 5.1.5621/4.0.4033
Mac Mini 6.2 (Quadcore i7)/MacBook Pro 3.1 (Core2Duo)
RME Fireface 800, driver version 3.122
User avatar
fl
 
Posts: 1198
Joined: Sun Feb 11, 2007 19:55
Location: Toronto, Ontario, Canada

Re: Pyramix Native 9.1.10 192 kHz playback issue

Postby Monsieur Z » Sun Feb 12, 2017 19:52

In the Pyramix Settings > Hardware > Formats&Sync page, on the right side under Audio Synchronization, what is shown in the Master Sync field? The Source Field? On my machine, there is only one option for both fields, so there's no choice. On your system, I would imagine that the Hammerfall automatically slaves to the Avocet, but I'm curious as to what is shown in the Pyramix Settings window.


Same as you, only one option. Actually, it is the other way around, the Avocet "slaves" itself to any incoming signal, but recreate a proper clock before actual playback (How ? no idea) Then again, if it was Avocet or sync related, the problem would rise also with 192 kHz playback from other software, which is not the case.

(Side note: Accessing the Hammerfall's Control Panel is best done through this Settings page when Pyramix is running, so that changes made there are immediately recognized by Pyramix. Calling the settings from the Hammerfall's Notification Area icon can sometimes cause some instability.)


I tried both ways earlier, and no problem either way, PMX update without problem.

Worse? That's strange - a larger latency buffer should reduce any clicking and popping, not make it worse.


I agree it goes against common sense. But some people had the same issue, see this thread : http://forum.merging.com/viewtopic.php?f=14&t=11533&p=35887&hilit=playback+buffer#p35887

Are you running any processor intensive plug-ins? Any concurrent programs or operations? You've mentioned that you've disabled Avast, but could there be any other process running that could affect your computer's performance? A tool like LatencyMon - http://www.resplendence.com/latencymon - could help track down likely culprits.


Not a single plug in. I will investigate the concurrent program lead (thanks for the link btw) but I hardly conceive a parallel processing that could interfere with 192 kHz playback but not with 96 or 44.1 kHz.

On that same page in the Settings, have you changed the Record Block Size to anything but 64 KB?


Nope, still 64 KB

I'm afraid I become a little bewildered when looking at that window - when playing back a six track, 96 kHz. project for the first time, my Transfer Rates are usually quite low, but if I stop playback and then immediately start again, the rates shown are much higher and can be all over the place - ramping up, down or just remaining so high that the panel becomes a solid green band. If I switch to a different project, or even just a different playlist within the same project, the first playback will show low Transfer rates, but any subsequent playback shows higher, although usually it's only for a short time, and then things ramp downward. At all times, playback proceeds without any clicks or pops, even if I reduce my Fireface's latency to 128 or even 96 samples, even when the displayed Transfer Rates exceed 2000 Mb/sec. Perhaps someone else has greater insight as to just what is being shown in that window.


I agree this window looks useless.

I have no idea what the problem is, but, as usual, those things rise when we need to get things done ASAP ! :evil:

Thanks for your input Frank.
Monsieur Z
 
Posts: 7
Joined: Fri Oct 25, 2013 12:25

Re: Pyramix Native 9.1.10 192 kHz playback issue

Postby Monsieur Z » Tue Feb 14, 2017 00:42

After sending my request to the support, Ricardo suggested that I installed DPC latency checker, and I did find a problem with my network wireless card (@#*[&) !
No more issue with a 128 buffer size, but the issue was still here in 256 and up, so, as Ricardo mentioned, I double checked the windows settings recommendations from Merging. I did them all already during installation of the program... except for the bios. All the 4 things to modify were in "auto" instead of "disabled".

Now everything is fine in any buffer size. :D

I must thank the Merging team, and Ricardo in particular for having responded to my email really fast !
Monsieur Z
 
Posts: 7
Joined: Fri Oct 25, 2013 12:25


Return to Pyramix General

Who is online

Users browsing this forum: No registered users and 8 guests