disabling mixer shortcuts?

Pyramix Native users forum
Forum rules
The Merging Technologies team cannot be held responsible for support queries logged on the public forums. If a support query is logged here and only here, it may not be found and dealt with by the appropriate team.
To ensure that your support issue or bug report is dealt with properly and in good time, please use the link to the tech support request form page on the Merging website.
Make sure to let us know what version you are using when you send your mail. THANKS!

disabling mixer shortcuts?

Postby jkurtz11 » Thu Oct 10, 2013 01:50

Apologies for this seemingly silly question, but one of my most annoying issues is that when I have the mixer window in the foreground, my zoom in and out shortcuts (down arrow and up arrow) sometimes act as shortcuts for muting and un-muting the selected mixer strip. This only seems to happen if I've manually muted the strip by clicking on it first, then push "up arrow" in an attempt to zoom out, which instead unmutes the strip. Then if I press down arrow after that it re-mutes it. I need to bring the main timeline window into the foreground, and then zooming works as expected.

I guess I have two questions - is there a way I can disable the shortcuts for muting and un-muting strips in the mixer? I've searched in the shortcut editor and can not find it.
Secondly, is there a way I can always have my zoom in/out shortcuts be active, even when the main timeline view is in the background?

Any help would be greatly appreciated.

Justin
jkurtz11
 
Posts: 24
Joined: Mon Jan 03, 2011 01:22

Re: disabling mixer shortcuts?

Postby fl » Thu Oct 10, 2013 16:23

I have not found any way to do what you are asking - insuring that the Timeline shortcuts are always in force. This is not the only type of issue associated with Pyramix's "focus". (The number of times I've inadvertently edited my session Notes (Notes Tab) when I intended to paste some text to a Marker...)

The only thing I've found is to have the top Toolbar Button for "Set Focus To Timeline" installed, so I can click on it maniacally anytime I feel the need. Also, I've been using the free utility "Wizmouse" - http://antibody-software.com/web/softwa ... the-mouse/ - to enable whatever window is under my mouse cursor, with mixed success.
Frank Lockwood, Toronto, ON, Canada
http://LockwoodARS.com
Native 11.0.6/Native Music 9.1.10
Win7 Pro SP1 64/32
Bootcamp 5.1.5621/4.0.4033
Mac Mini 6.2 (Quadcore i7)/MacBook Pro 3.1 (Core2Duo)
RME Fireface 800, driver version 3.123
User avatar
fl
 
Posts: 1235
Joined: Sun Feb 11, 2007 19:55
Location: Toronto, Ontario, Canada

Re: disabling mixer shortcuts?

Postby jkurtz11 » Sun Oct 13, 2013 01:18

Thanks for the info Frank. I can live with having to bring the timeline to the foreground manually, but I'd really like to not have keyboard shortcuts for muting a strip. This is extremely dangerous when I am doing a live mix that I do not want to inadvertently mute a strip. Any idea where that may be in the keyboard shortcut editor so I can disable it?
jkurtz11
 
Posts: 24
Joined: Mon Jan 03, 2011 01:22

Re: disabling mixer shortcuts?

Postby fl » Sun Oct 13, 2013 21:08

jkurtz11 wrote:I'd really like to not have keyboard shortcuts for muting a strip.


I don't think I've ever used keyboard shortcuts for the mixer - what key combination are you using that mutes a strip?

I'm wondering if, in the absence of the ability to change or disable mixer shortcuts, the workaround would be to change the shortcut that you wish to use in the main window (the one that triggers the strip muting, whenever the mixer is still the object of "focus"), to some other key combination. Not a great solution, but it could keep you safe.
Frank Lockwood, Toronto, ON, Canada
http://LockwoodARS.com
Native 11.0.6/Native Music 9.1.10
Win7 Pro SP1 64/32
Bootcamp 5.1.5621/4.0.4033
Mac Mini 6.2 (Quadcore i7)/MacBook Pro 3.1 (Core2Duo)
RME Fireface 800, driver version 3.123
User avatar
fl
 
Posts: 1235
Joined: Sun Feb 11, 2007 19:55
Location: Toronto, Ontario, Canada

Re: disabling mixer shortcuts?

Postby jkurtz11 » Sun Oct 13, 2013 22:50

It happens to be the up arrow and down arrow keys, which is a holdover from my sonic days. The weird thing is, it only mutes a strip if I've already muted it manually first, then up arrow unmutes it, and down arrow re-mutes it. I have reassigned my zoom shortcuts to something else in the meantime. Maybe it'll end up staying that way, but it just seems weird.
jkurtz11
 
Posts: 24
Joined: Mon Jan 03, 2011 01:22

Re: disabling mixer shortcuts?

Postby fl » Sun Oct 13, 2013 23:53

Well isn't that the darndest thing! I've never used my arrow keys for anything other than, well, arrow keys, but I have the same behaviour: muting and unmuting a strip, but only that strip, and only after I've mouse-click muted it once.

If I shift focus to the Timeline by clicking on a track header, I no longer mute and unmute - I just move my track selection up or down.

Here's the wrinkle: when I focus back on the mixer, the up/down arrows no longer mute or unmute the previously affected strip - or any strip, for that matter. I can only re-establish this arrow key behaviour if I once again mute and unmute a strip with a mouse click or two.

I think what we've got here is a bug, not a feature, and we should probably let the Merging folks know directly, as they don't always monitor this forum.
Frank Lockwood, Toronto, ON, Canada
http://LockwoodARS.com
Native 11.0.6/Native Music 9.1.10
Win7 Pro SP1 64/32
Bootcamp 5.1.5621/4.0.4033
Mac Mini 6.2 (Quadcore i7)/MacBook Pro 3.1 (Core2Duo)
RME Fireface 800, driver version 3.123
User avatar
fl
 
Posts: 1235
Joined: Sun Feb 11, 2007 19:55
Location: Toronto, Ontario, Canada

Re: disabling mixer shortcuts?

Postby rathammer » Sat Dec 07, 2013 20:24

Hello!

actually, I have the same issue: up/down arrows seem to act as "toggle" for whatever mixer element was active. I use up/down as well for zooming (old "sonic" habit...) and found that those keys also move the faders up/down in 0,1dB increments if the fader was the element used previously or they toggle mute if this was the element switched before.

I've often wanted to just insulate the mixer from any shortcuts because I would not need them any time. But it does not seem to be possible.

@ Nicolas / Ricardo: Is there any way to improve this for v9?
___________________________
Andreas Rathammer • QUINTON
www.quintonrecords.com
Vienna / Austria / Europe
rathammer
 
Posts: 36
Joined: Wed May 15, 2002 20:47
Location: Vienna | Austria | Europe

Re: disabling mixer shortcuts?

Postby J.Wajer » Sun Dec 08, 2013 10:12

There are more issues with double shortcuts related to active windowing. I still sometimes accidentally throw away libraryshelfs when I think I am actually deleting a clip. We badly need visual feedback for the active window! Which is completely logical because Merging provides us with double/triple meaning of keyboardshortcuts. You cant expect us to remember which tab, window or mixer we pressed last.
...Gracefully Ignored...
User avatar
J.Wajer
 
Posts: 1675
Joined: Tue Dec 18, 2007 10:25
Location: Amsterdam, Netherlands

Re: disabling mixer shortcuts?

Postby rathammer » Sun Dec 08, 2013 11:34

By all means - double shortcuts should be eliminated at all because they are really dangerous. Merging: is this possible?
___________________________
Andreas Rathammer • QUINTON
www.quintonrecords.com
Vienna / Austria / Europe
rathammer
 
Posts: 36
Joined: Wed May 15, 2002 20:47
Location: Vienna | Austria | Europe

Re: disabling mixer shortcuts?

Postby J.Wajer » Mon Dec 09, 2013 12:05

Well no, double shortcuts are very handy actually. I use them all the time, and without noticing. F.I. the shortcuts for play-stop in the media manager are the same for transport. But nevertheless, many times I press play (transport) while in effect a media from the media manager starts playing, because the focus is still on that tab. Some sort of visual feedback indicating the active window would eliminate that confusion once and for all...
...Gracefully Ignored...
User avatar
J.Wajer
 
Posts: 1675
Joined: Tue Dec 18, 2007 10:25
Location: Amsterdam, Netherlands

Re: disabling mixer shortcuts?

Postby rathammer » Mon Dec 09, 2013 12:35

J.Wajer wrote:I use them all the time, and without noticing. F.I. the shortcuts for play-stop in the media manager are the same for transport. But nevertheless, many times I press play (transport) while in effect a media from the media manager sta


Exactly! This is why it would be great to have the media-manager-player e.g. on shift-space or somewhere else. Because it happens so often that media manager starts generating a waveform of a 2-hour-file and blocking the system while nobody (and also the clients) sit and wonder, just to end up hearing a wrong sound out of the speakers. Not very sexy.

I don't think think that a red frame around the media manager window would stop me from instinctively hitting play when i want to start the timeline playing. At least for me that wouldn't work.

That's why all GEAR actually has a dedicated button for the most essential functions at least. No?
___________________________
Andreas Rathammer • QUINTON
www.quintonrecords.com
Vienna / Austria / Europe
rathammer
 
Posts: 36
Joined: Wed May 15, 2002 20:47
Location: Vienna | Austria | Europe

Re: disabling mixer shortcuts?

Postby tim » Tue Dec 31, 2013 19:14

Hi all, sorry to enter late into this discussion. Please see viewtopic.php?f=8&t=6567 along with many of your replies at the time. A few users contacted Dominique Brulhart, and agreed that the primary issue was in fact the four arrow keys. What we wanted was a settings option which would disable the arrow keys from any mixer control...so that the arrows would only be timeline-directed, even if the mixer was in focus. Dom indicated that if enough users requested such an option, it could be added as a check box in Settings. This never came about - maybe we could revisit this request.

However, Dom created a registry key which would accomplish exactly that - disabling the arrow keys from mixer control. It takes 5 seconds to install, and it's at the top of my "to do" list with every new Pyramix install. Please contact Dominique at support@merging.com to request the "No VS3 keyboard command" registry key. If enough users request it, maybe Merging will add the option.

Best wishes,

Tim
Tim Martyn
Phoenix Audio
Glen Rock, NJ
www.phoenixaudiollc.com
tim
 
Posts: 292
Joined: Fri May 17, 2002 05:10
Location: Glen Rock, New Jersey USA

Re: disabling mixer shortcuts?

Postby David Jacques » Fri Jan 03, 2014 13:26

You can download this registry key here:
http://download.merging.com/beta/AssociatedTools/NoVS3KeyboardCommand.zip

Extract the zip file and double click on the .reg file to have it included in your Windows registry.
You have to restart Pyramix to enable this option.

Please also note that it is user-based, you have to enable it for each user if you have several user accounts.
David Jacques
 
Posts: 129
Joined: Tue Nov 03, 2009 11:31

Re: disabling mixer shortcuts?

Postby fl » Fri Jan 03, 2014 19:57

While I can certainly understand the desire to totally disable the use of keyboard commands for the mixer, there are times when I find this useful, such as when I want to have fine control of the panpot. As I was never a Sonic user, I never developed arrow key reflexes for the mixer, so if you're like me, you might not want to use the registry modification that David just made available.

I think that Jaap's suggestion of some obvious indication as to which window has the current focus is a great one, as I too like having some keyboard shortcuts that do more than one thing, depending on the current focus.

However, what I would REALLY like to see is an option to enable a "Focus Follows Cursor" function, so that wherever your mouse cursor is located, that's the thing that receives mouse and keyboard control. This would be of particular help when I'm using the Notes Tab, and then switch back to the timeline, where I find find that my keyboard entries do not have the desired effect until I mouse-click somewhere, then discover later that I've made a mess of my Notes.

As mentioned before, this is the main reason I've installed WizMouse on my machines - not the background window scrolling which seems to get emphaisized in its product literature (although that's handy too). I grew used to this kind of cursor/focus behaviour back when I was using an Atari, and later on the Mac. Windows never incorporated this function, hence the development of WizMouse. It works pretty well, and has a very light processing and memory footprint. Sadly it does not solve my Notes issue, but it does remove the keyboard focus on the mixer, provided I move my cursor.

http://antibody-software.com/web/softwa ... the-mouse/

Apparently, it has not been upgraded to work with Windows 8 (not that that would affect anyone here...), so here are a few alternatives:

KatMouse: http://ehiti.de/katmouse/
Always Mouse Wheel: http://www.softwareok.com/?seite=Micros ... MouseWheel
Mouse Hunter: http://www.amlpages.com/mousehunter.shtml
Frank Lockwood, Toronto, ON, Canada
http://LockwoodARS.com
Native 11.0.6/Native Music 9.1.10
Win7 Pro SP1 64/32
Bootcamp 5.1.5621/4.0.4033
Mac Mini 6.2 (Quadcore i7)/MacBook Pro 3.1 (Core2Duo)
RME Fireface 800, driver version 3.123
User avatar
fl
 
Posts: 1235
Joined: Sun Feb 11, 2007 19:55
Location: Toronto, Ontario, Canada


Return to Pyramix Native

Who is online

Users browsing this forum: No registered users and 2 guests