clip snapping

Pyramix Native users forum
Forum rules
The Merging Technologies team cannot be held responsible for support queries logged on the public forums. If a support query is logged here and only here, it may not be found and dealt with by the appropriate team.
To ensure that your support issue or bug report is dealt with properly and in good time, please use the link to the tech support request form page on the Merging website.
Make sure to let us know what version you are using when you send your mail. THANKS!
ppet
Posts: 9
Joined: Sat Mar 27, 2010 18:17

clip snapping

Postby ppet » Tue Sep 14, 2010 08:21

Hi,
I've a novice problem, I'm not able to snap a clip selection to another one (head to tail for example) or to a bar line when moving it horizontally. I tried all the "snap" and editing modes, but cannot achieve this simple need as we can do it with Sonar for example. Is there something known as unworking in this area ?
I'm experimenting a bug too : when "horizontal move " is locked I still can drag a selection horizontally.
My versions: last pyramix native 6.2 sp1, windows xp pro 32

thanks for your help !
Philippe

AndyR
Posts: 54
Joined: Wed Feb 04, 2009 19:26

Re: clip snapping

Postby AndyR » Tue Sep 14, 2010 11:26

There's a shortcut!
try holding down 'H' key while you drag. clips will then snap to cursor, and to other clips ends/beginnings.

Hope that's what you're after
Andy

ppet
Posts: 9
Joined: Sat Mar 27, 2010 18:17

Re: clip snapping

Postby ppet » Tue Sep 14, 2010 19:54

Hi Andy
Thanks for your help. I tested it with a 6.1.8 mr2 at home, it's working, and working best if setting beats in the "view bars and beats settings" to 1/4 (i had 1/16 set and the snapping wasn't very noticeable with a x1 zooming).
I'll try this at the studio tomorrow on the 6.2.4 sp1, but I still have the bug of unworking horizontal lock with the 6.2.4 sp2

Cheers
Philippe

User avatar
Paulo M
Posts: 1444
Joined: Wed Jun 01, 2005 16:19
Location: Portugal

Re: clip snapping

Postby Paulo M » Wed Sep 15, 2010 12:29

but I still have the bug of unworking horizontal lock with the 6.2.4 sp2


Hi Philippe,

It´s not a bug. It happens because on Settings/Application/Editing you have Auto-Crossfade by default-Control key for Drag&Drop enabled.

If you disable it, when lock horizontal is engaged you can´t horizontally move your clips unless holding Ctrl while dragging.

Another way to provent the clips being moved is to use Lock, although this will prevent all editing which I guess is not what you want.

Hope it helps
Best regards,

Paulo M

Pyramix 7.1 Masscore
VCube XE 3.1
MB5 Dual & X50 MADI
Win XP SP3
Intel Q9600/Gigabyte X48 DS5 Motherboard/ASUS 4350 Graphic card

ppet
Posts: 9
Joined: Sat Mar 27, 2010 18:17

Re: clip snapping

Postby ppet » Mon Sep 20, 2010 08:55

Hi Paulo,
Yes it was this !....
thank you for your help, everything's fine now.
Philippe

avi
Posts: 310
Joined: Mon Nov 08, 2004 00:10
Location: London, UK

Re: clip snapping

Postby avi » Mon Sep 20, 2010 20:18

AndyR wrote:There's a shortcut!
try holding down 'H' key while you drag. clips will then snap to cursor, and to other clips ends/beginnings.

Hope that's what you're after
Andy


And there's another:
H snaps the head of the clip to the nearest object (cursor, tail of the previous clip, in or out marker)
T snaps the tail of the clip to the nearest...

(assuming you haven't altered the default PMX shortcut keys, of course!)


AVI
Alexander Van Ingen
Six Music Productions
www.sixmp.co.uk