ASIO4ALL and Sample Rates above 48 kHz.

Pyramix Native users forum
Forum rules
The Merging Technologies team cannot be held responsible for support queries logged on the public forums. If a support query is logged here and only here, it may not be found and dealt with by the appropriate team.
To ensure that your support issue or bug report is dealt with properly and in good time, please use the link to the tech support request form page on the Merging website.
Make sure to let us know what version you are using when you send your mail. THANKS!
User avatar
fl
Posts: 1291
Joined: Sun Feb 11, 2007 19:55
Location: Toronto, Ontario, Canada
Contact:

ASIO4ALL and Sample Rates above 48 kHz.

Postby fl » Sat Jun 12, 2010 19:19

For those who use ASIO4ALL as a convenient way to monitor Pyramix Native output through a computer's onboard RealTek audio hardware, for those times you don't want to carry around any additional hardware:

1. Enable ASIO4ALL as the preferred ASIO device in the Merging VS3 Control Panel.
2. Open Pyramix and open the Formats & Sync Settings, then open the ASIO4ALL Control Panel (it's best to do this in the audio application).
3. Click on the icon in the lower right corner shaped like a wrench (Advanced Settings).
4. Disable all audio devices except the RealTek High Definition Audio device by clicking on the little right-pointing arrows next to the names. The field to the left of the arrow should go blank.
5. Expand the RealTek High Definition Audio device to show all its components (click on the little "+"sign next to the name).
6. Disable (same method as above with the arrow shaped icon) all Inputs - there should be two, one for Analog and one for Digital.
7. This should leave one item active, the RealTek HD Audio Output, and it should show that it is capable of output of SR up to 192 kHz. and 32 bits.
8. Click on the name "RealTek HD Audio Output" to highlight it.
9. Drag the ASIO Buffer Size slider (bottom of window) all the way to the right for 2048 samples.
10. Drag the Latency Compensation sliders (top right) all the way to the right for 1024 samples.
11. Leave all the check boxes unchecked (Hardware Buffer, Always resample 44.1 <-> 48, and Force WDM driver to 16 bit).

With the buffers maxed out like this, you should have click-free audio playback output for high sample rates.
Frank Lockwood, Toronto, ON, Canada
http://LockwoodARS.com
Native 11.1.5
Win7 Pro SP1 64
Bootcamp 5.1.5621
Mac Mini 6.2 (Quadcore i7)
RME Fireface 800, driver version 3.125

User avatar
fl
Posts: 1291
Joined: Sun Feb 11, 2007 19:55
Location: Toronto, Ontario, Canada
Contact:

Re: ASIO4ALL and Sample Rates above 48 kHz.

Postby fl » Tue Jun 22, 2010 16:35

The instructions I posted above apply to ASIO4ALL version 2.09. In the meantime, version 2.10 has been released, which has some differences in how the audio hardware is displayed.

The principle, however, remains the same - in the ASIO4ALL Advanced Settings, disable the RealTek Input devices, leaving the Output enabled by itself. Max out both the Buffer Size and the Latency Compensation sliders, and leave all the checkboxes unchecked.
Frank Lockwood, Toronto, ON, Canada
http://LockwoodARS.com
Native 11.1.5
Win7 Pro SP1 64
Bootcamp 5.1.5621
Mac Mini 6.2 (Quadcore i7)
RME Fireface 800, driver version 3.125

Zanulite
Posts: 26
Joined: Mon Sep 20, 2010 14:32
Location: Calgary, Alberta, Canada
Contact:

Re: ASIO4ALL and Sample Rates above 48 kHz.

Postby Zanulite » Tue Feb 22, 2011 11:09

Hi,
I followed instruction exactly step by step multiples times, and it still does not play back high sample rate projects. Using Pyramix Native 7 with windows 7 and asio4all drivers.
May be somebody encountered this problem too?
First you open the project asio4all shows that it is "beyond Logic". I am trying to reset it, disabling all inputs and leaving only 1 output, as a result the sample rate of the pyramix project switches to 44.1. Whatever I do after this changing multiple times sample rate, it just comes back to 44.1 without ever switching back. As a result no high sample rate project could be played back at correct sample rate....
I wonder what I am doing wrong, and if someone actually can play high sample rate projects on pyramix 7 using the onboard sound card with asio4all...
Zana Corbett
Freelance Audio Engineer
Calgary, Alberta, Canada

User avatar
phaseboy
Posts: 503
Joined: Thu Nov 21, 2002 23:41
Location: London, UK
Contact:

Re: ASIO4ALL and Sample Rates above 48 kHz.

Postby phaseboy » Tue Feb 22, 2011 17:49

Your onboard sound card still needs to support the high sample rates. Some support up to 192, some 96, and some still only 48. I would suspect that your soundcard only supports 44.1/48.

Regards,

Mark
Mark S. Willsher
http://www.pin3hot.com

User avatar
Graemme
Posts: 2204
Joined: Wed May 15, 2002 22:18
Location: Vancouver, BC, Canada
Contact:

Re: ASIO4ALL and Sample Rates above 48 kHz.

Postby Graemme » Tue Feb 22, 2011 23:03

Zanulite wrote:Hi,
I followed instruction exactly...


You need to tell us which computer you are using...it's hard to offer advice without some info about your system.

My 'old' MacBook Pro (1st gen. CoreDuo) only has a 48K max audio capability and ASIO4ALL can't so anything about that.

As Mark said, it's entirely dependent on your hardware.

Graemme
Graemme Brown
Zen Mastering
1460 Wild Rose Drive
Gabriola Island, BC
Canada V0R 1X5
+1.604.874.9096

"A Horus, A Horus; My Kingdom for a Horus!"

Zanulite
Posts: 26
Joined: Mon Sep 20, 2010 14:32
Location: Calgary, Alberta, Canada
Contact:

Re: ASIO4ALL and Sample Rates above 48 kHz.

Postby Zanulite » Wed Feb 23, 2011 00:59

I have imac 2.66 Ghz with Snow leopard and windows 7 32 bit. Everything worked for me fine while i had XP and 6 version since 6 version had native direct audio support.
I already uninstall and reinstall boot-camp a couple of times. So all drivers are installed as I installed bootcamp from Snow leopard DVD.
I also have compaq presario laptop F700. Which has similar problem. When 2FS files are opened there is no sound coming if i press play.It just does not play at all.

I wonder if there is a way to tweak thos asio4all drivers.
Zana Corbett
Freelance Audio Engineer
Calgary, Alberta, Canada

Zanulite
Posts: 26
Joined: Mon Sep 20, 2010 14:32
Location: Calgary, Alberta, Canada
Contact:

Re: ASIO4ALL and Sample Rates above 48 kHz.

Postby Zanulite » Wed Feb 23, 2011 04:35

Ok so after spending all day trying to solve this issue, I still can't play 2fs 88.2 files.
I have pyramix 7 with service pack 2. I downloaded the latest realtek 257 codec for vista and windows 7.
I am doing the steps in the next order.
Loading VS 3 choosing Asio4all, then loading pyramix, then setting the sample rate in format and sync , increase buffer of asio4all. Open the project and when I press play, there is no sound. Go again to format and sync open asio4all disable, enable, closing. Mixing windows reloads and sample rate jumps to 44.1. This happens on my compaq laptop and on my bootcamp... Difference is that on compaq the asio4all buffer in the vs3 panel is 512 samples, on bootcamp it is 2054...


But the most interesting thing is that I am able to open 96KHz project on my laptop and on my bootcamp imac and plays back with asio4all. And it plays back fine .... I have no idea, what is going on and how is it 88.2 differs so much from 96Khz. If I can hear 96Khz, clearly that sound card is supporting 88.2 also....

This is not a big projects, no editing and only 6 channels...

Still looking for solutions...
Zana Corbett
Freelance Audio Engineer
Calgary, Alberta, Canada

User avatar
Graemme
Posts: 2204
Joined: Wed May 15, 2002 22:18
Location: Vancouver, BC, Canada
Contact:

Re: ASIO4ALL and Sample Rates above 48 kHz.

Postby Graemme » Wed Feb 23, 2011 05:41

Zanulite wrote:If I can hear 96Khz, clearly that sound card is supporting 88.2 also...


Well, we all might like to think so! However, I have at least two bits of gear that omit 88K2 as a usable sample rate, while supporting 96K, etc.(Beyer Headzone; older Yamaha recorder.)

Have you checked in with the ASIO4ALL developer?

Graemme
Graemme Brown
Zen Mastering
1460 Wild Rose Drive
Gabriola Island, BC
Canada V0R 1X5
+1.604.874.9096

"A Horus, A Horus; My Kingdom for a Horus!"

User avatar
phaseboy
Posts: 503
Joined: Thu Nov 21, 2002 23:41
Location: London, UK
Contact:

Re: ASIO4ALL and Sample Rates above 48 kHz.

Postby phaseboy » Wed Feb 23, 2011 05:53

Zanulite wrote:If I can hear 96Khz, clearly that sound card is supporting 88.2 also...


As Graemme has nicely intimated - you cannot assume this. Aside from old gear - I have seen current computer sound cards that support 44.1/48/96, but not 88.2. That's not to say yours doesn't, but it's not a foregone conclusion by any stretch.
Mark S. Willsher
http://www.pin3hot.com

User avatar
fl
Posts: 1291
Joined: Sun Feb 11, 2007 19:55
Location: Toronto, Ontario, Canada
Contact:

Re: ASIO4ALL and Sample Rates above 48 kHz.

Postby fl » Wed Feb 23, 2011 08:06

Zanulite wrote:Ok so after spending all day trying to solve this issue, I still can't play 2fs 88.2 files.
I have pyramix 7 with service pack 2. I downloaded the latest realtek 257 codec for vista and windows 7.


It's been my experience that more recent Realtek drivers aren't all that compatible with Bootcamp/Macs - I think it's better to stick with the drivers that come with Bootcamp. Do you know that there is a more recent version of Bootcamp than the one that comes on the Snow Leopard disk? Maybe give that a try - but don't change the RealTek drivers from those that come with Bootcamp.

Check the Windows "Sounds and Audio Devices" Control Panel - make sure that System Sounds are set to "No Sounds".

In Pyramix's Settings > Formats and Sync, is the Master Sync set to "Board ASIO4All v2"? Is the Source set to "Big Ben"?

Zanulite wrote:I am doing the steps in the next order.
Loading VS 3 choosing Asio4all, then loading pyramix, then setting the sample rate in format and sync , increase buffer of asio4all. Open the project and when I press play, there is no sound.


When you enable the RealTek drivers, a control panel - the "Realtek HD Sound Effect Manager" - will become available in the lower right corner of your taskbar (I use XP so this may be different in Windows 7). Make sure that no funky settings are enabled in there, like the Karioke setting, or the various playback environments. Make sure that all that stuff is turned off. Make sure that there is no random setting in there that could be interfering with routing your output to the main outputs 1 and 2.

I was able to abuse my system, which is similar to yours, so that it began to behave as you have described, but only briefly. In the ASIO4ALL settings panel, I got the "Beyond Logic" symbol when I first opened Pyramix with no project loaded, but the sample rate being set (from the last time I used Pyramix) at 88.2 kHz. Changing this to 44.1 and then re-opening the ASIO4ALL control panel showed that the "Beyond Logic" symbols were gone now. I then loaded an 88.2 project, which automatically changed Pyramix to 88.2, and everything worked as it should.

When you say "there is no sound", does this mean that the Pyramix cursor moves, or not?

I've encountered the situation where some sessions will open in Pyramix but the playback will stall - the green "Play" icon is illuminated in the transport controls, but the cursor doesn't move and there is no sound output. The fix is to re-build the Mixer by going to its Configure page and making some small change, and then going back to the main Mixer window. Then, sometimes, the project behaves as it should.

If the cursor is moving, and there is no sound, then make sure that everything is configured properly in the Monitor window - or else simply route the output of your main mixer output bus directly to the first two ASIO4ALL output channels (bypassing the Monitor section completely). In either case, make sure that your output is indeed going to "ASIO4ALL v2 Bank 0 -> 1 (HD Audio Output 1)" and "2 (HD Audio Output 2)".

Hope this helps - good luck.
Frank Lockwood, Toronto, ON, Canada
http://LockwoodARS.com
Native 11.1.5
Win7 Pro SP1 64
Bootcamp 5.1.5621
Mac Mini 6.2 (Quadcore i7)
RME Fireface 800, driver version 3.125

Zanulite
Posts: 26
Joined: Mon Sep 20, 2010 14:32
Location: Calgary, Alberta, Canada
Contact:

Re: ASIO4ALL and Sample Rates above 48 kHz.

Postby Zanulite » Wed Feb 23, 2011 18:04

Thanks for all replies,
In Pyramix's Settings > Formats and Sync, is the Master Sync set to "Board ASIO4All v2"? Is the Source set to "Big Ben"? Exactly
Realtek all bathroom environments and specials effects are off.

Then you say "there is no sound", does this mean that the Pyramix cursor moves, or not?

I've encountered the situation where some sessions will open in Pyramix but the playback will stall - the green "Play" icon is illuminated in the transport controls, but the cursor doesn't move and there is no sound output. The fix is to re-build the Mixer by going to its Configure page and making some small change, and then going back to the main Mixer window. Then, sometimes, the project behaves as it should.

Exactly this is what is happening, the Play icon is illuminated in the transport control, but nothing moves and cursor does not move, so no sound is coming to the strips, so nothing is going out.

Monitoring section is off, the main outputs are routed to the correct outs.

I think since everything is working fine with 96Khz, it means the problem is the realtek driver. Asio4All supports every sample rate which is supported by the sound card. But in the realtek panel if I want to choose some default sample rate, there is no choose of 88Khz. Only 44, 48, 96, 192. Probably this is the thing. Also I got some replies from colleagues that they also encountered this problem with MacBooks and 88Khz. Apparently MacBooks does not support 88Khz at all. Maybe the same thing is happening with Imacs.

I download the newest realtek driver and install instead of realtek from the bootcamp DVD. Also I can't install separate Segmatel drivers, since there is an error which says that this hardware is not found. Probably on DVD they put all possible drivers for all possible configuration of mac, when when I run bootcamp it seems that Sigmatel drivers are getting installed. But if later i want to install them again i have this error. I think the realtek drivers are probably more suitable for iMac internal soundcards...

I guess since on my compaq laptop I also have realtek the same thing is happening there...
Zana Corbett
Freelance Audio Engineer
Calgary, Alberta, Canada

User avatar
Carl Schuurbiers
Posts: 5
Joined: Thu May 16, 2002 15:50
Location: Munich, Germany
Contact:

Re: ASIO4ALL and Sample Rates above 48 kHz.

Postby Carl Schuurbiers » Tue Mar 15, 2011 19:13

Graemme wrote:My 'old' MacBook Pro (1st gen. CoreDuo) only has a 48K max audio capability and ASIO4ALL can't so anything about that.
Graemme


Dear Graemme,

Are you sure about this? I have the same "old" :wink: CoreDuo MacBook Pro (early 2006 model), which does support 88k2 and 96k under Mac OSX. The same computer also runs Pyramix Native under Windows XP. I recall being able to listen to 88k2 projects through the headphone output of the laptop in version 6.2. However this was already some time ago, and I'm not 100% sure any more. In the mean time I upgraded Pyramix to v7 so can't double-check it now, but I was surprised that it didn't work when I wanted to do this recently. I mainly use the RME MADIFace and/or Mykerinos AES/EBU for I/O, but it's very convenient to be able to play projects with just the laptop occasionally. Convenient enough to invest some time to get to the bottom of it..

Have you used the MacBook Pro with Pyramix Native v6.2? No 88k2 for sure?
Does anybody else have any experience with this configuration, working before at 88k2 in v6.2 and now with v7 SP2 and ASIO4ALL (v2.10) only 44k1 and 48k available?

Thanks,

Carl.
Carl Schuurbiers
https://videotonart.de

User avatar
Graemme
Posts: 2204
Joined: Wed May 15, 2002 22:18
Location: Vancouver, BC, Canada
Contact:

Re: ASIO4ALL and Sample Rates above 48 kHz.

Postby Graemme » Tue Mar 15, 2011 22:51

Hi Carl,

I don't have all of the details with me right now but check this post from the ASIO4ALL support site:

http://mtippach.proboards.com/index.cgi ... age=1#2889

My (and maybe your) MacBook Pro uses the SigmaTel chipset and not the RealTek that Apple later switched to.

More info when I get home...

Graemme
Graemme Brown
Zen Mastering
1460 Wild Rose Drive
Gabriola Island, BC
Canada V0R 1X5
+1.604.874.9096

"A Horus, A Horus; My Kingdom for a Horus!"

User avatar
Carl Schuurbiers
Posts: 5
Joined: Thu May 16, 2002 15:50
Location: Munich, Germany
Contact:

Re: ASIO4ALL and Sample Rates above 48 kHz.

Postby Carl Schuurbiers » Thu Mar 17, 2011 23:16

In the mean time I found a workaround: enabling samplerate conversion in general preferences. Now I can open 88k2 projects and play them through ASIO4ALL at 44k1.

But I remain interested in solving the real problem...

Carl.
Carl Schuurbiers
https://videotonart.de

User avatar
Graemme
Posts: 2204
Joined: Wed May 15, 2002 22:18
Location: Vancouver, BC, Canada
Contact:

Re: ASIO4ALL and Sample Rates above 48 kHz.

Postby Graemme » Fri Mar 18, 2011 01:07

The 'Real problem' is that recent versions of ASIO4ALL have blacklisted the SigmaTel driver for rates above 48K. The chipset itself supports 44K1, 48K, 96K and something called 'Dynamic' but SigmaTel's driver is apparently very problematic outside of the two 1fs rates.

Your workaround is likely to be about as good as it will ever get...

Graemme
Graemme Brown
Zen Mastering
1460 Wild Rose Drive
Gabriola Island, BC
Canada V0R 1X5
+1.604.874.9096

"A Horus, A Horus; My Kingdom for a Horus!"