Delay experience w. RME HDSPe MADIface

Pyramix Native users forum
Forum rules
The Merging Technologies team cannot be held responsible for support queries logged on the public forums. If a support query is logged here and only here, it may not be found and dealt with by the appropriate team.
To ensure that your support issue or bug report is dealt with properly and in good time, please use the link to the tech support request form page on the Merging website.
Make sure to let us know what version you are using when you send your mail. THANKS!
gabriel
Posts: 139
Joined: Thu May 16, 2002 01:24
Location: Zurich, Switzerland

Delay experience w. RME HDSPe MADIface

Postby gabriel » Thu Nov 26, 2009 22:46

Dear all,

I'm looking for any throughput delay results of Pyramix Native in combination with a MADI stagebox and an RME HDSPe MADIface (ExpressCard). And btw: how is interoperability of RME card with Pyramix Native?

Many thanks in advance

Gabriel

gabriel
Posts: 139
Joined: Thu May 16, 2002 01:24
Location: Zurich, Switzerland

Re: Delay experience w. RME HDSPe MADIface

Postby gabriel » Wed Mar 17, 2010 01:01

Answering myself after buying RME Micstasy M and HDSPe MADIface, running into a Macbook Pro Intel Core 2 Duo 2.8 GHz. Measurement path is RME Micstasy mic input at fs=48 kHz, delay compensation ON (for daisy chaining several Micstasys), RME MADIface (ExpressCard), Pyramix native simple mixer loop with input recording to disk on 24 tracks@24 bit and strip tools with eq in every channel, MADIface, output of Pyramix routed back to Micstasy and set for Digital Output, MOTU 2408 converting ADAT output of MIcstasy to analogue.

Pyramix native v6.2 with Windows XP SP2 32bit:
- MADIface ASIO buffer setting=32 results in roundtrip delay of 178 samples (3.7 ms), but with lots of clicks
- MADIface ASIO buffer setting=64 results in roundtrip delay of 241 samples (5 ms), but with clicks
- MADIface ASIO buffer setting=128 results in roundtrip delay of 370 samples (7.7 ms), no more clicks

Logic 9 (similar configured as Pyramix) with Mac OSX 10.6:
- Core Audio I/O buffer setting=32 samples results in troubles with recording to disk
- Core Audio I/O buffer setting=64 samples results in roundtrip delay of 226 samples (4.7 ms), recording to disk now working

RME TotalMix hardware monitoring
- results in 82 samples (1.7 ms), where 0.25 ms is from Micstasy AD converter, 0.437 ms (21 samples) from delay compensation and rest (1 ms) sourced from DA converter and TotalMix

I tried to find the bottleneck with Windows/Pyramix, but different configurations of Pyramix with different load (no equalizers, less tracks, digitizing project) seemed to have no influence on clicks. CPU load was also pretty low. Since RME hardware monitor worked without problems, it looks like an issue between RME MADIface and Pyramix, probably Windows and/or ASIO driver limit. Logic 9 with OSX 10.6 clearly increased CPU load with lower buffer settings.

Gabriel

David Jacques
Posts: 133
Joined: Tue Nov 03, 2009 11:31

Re: Delay experience w. RME HDSPe MADIface

Postby David Jacques » Wed Mar 17, 2010 13:33

Did you read this page regarding bootcamp and Pyramix :
http://forum.merging.com/viewtopic.php?t=3765

User avatar
fl
Posts: 1303
Joined: Sun Feb 11, 2007 19:55
Location: Toronto, Ontario, Canada
Contact:

Re: Delay experience w. RME HDSPe MADIface

Postby fl » Wed Mar 17, 2010 15:32

David Jacques wrote:Did you read this page regarding bootcamp and Pyramix :
http://forum.merging.com/viewtopic.php?t=3765


That was posted in 2008, and since then NVDIA has issued updates of its own for the drivers, which improve things significantly, so the laptop2go drivers are not strictly necessary any more. The NVDIA drivers that come with Boot Camp 3.0/3.1 are now sufficiently recent to offer the low DPC latencies - and are certain to run properly with the Mac hardware.
Frank Lockwood, Toronto, ON, Canada
http://LockwoodARS.com
Native 11.1.5
Win7 Pro SP1 64
Bootcamp 5.1.5621
Mac Mini 6.2 (Quadcore i7)
RME Fireface 800, driver version 3.125

gabriel
Posts: 139
Joined: Thu May 16, 2002 01:24
Location: Zurich, Switzerland

Re: Delay experience w. RME HDSPe MADIface

Postby gabriel » Thu Mar 18, 2010 02:41

In fact it works on both OS with correct buffer settings. If I really need lowest delay, I can use the HW monitoring of RME. The good thing is, you can configure TotalMix even for an M/S decoder. The only problem I still have in Windows is a conflict between an application of the onboard audio chip and RME. Yet, it's not possible to select the internal audio as an output device, which would be nice sometimes. As soon as the RME MADIface is ejected from the Macbook, the conflict disappears and output thru onboard audio is possible again. Any hints for that?

cheers, Gabriel

User avatar
fl
Posts: 1303
Joined: Sun Feb 11, 2007 19:55
Location: Toronto, Ontario, Canada
Contact:

Re: Delay experience w. RME HDSPe MADIface

Postby fl » Thu Mar 18, 2010 03:04

The latest Realtek audio drivers get along better with the RME drivers.

http://www.realtek.com.tw/DOWNLOADS/dow ... Down=false
Frank Lockwood, Toronto, ON, Canada
http://LockwoodARS.com
Native 11.1.5
Win7 Pro SP1 64
Bootcamp 5.1.5621
Mac Mini 6.2 (Quadcore i7)
RME Fireface 800, driver version 3.125

gabriel
Posts: 139
Joined: Thu May 16, 2002 01:24
Location: Zurich, Switzerland

Re: Delay experience w. RME HDSPe MADIface

Postby gabriel » Thu Mar 18, 2010 03:42

Just that simple?

Many thanks, Gabriel