Page 1 of 1

Failing to (re)install Pyramix

Posted: Sat Dec 01, 2018 18:47
by OlleGrane

I was stupidly running a cleaning / performance enhancing software (Magix PC Check & Tuning 2019) that came along with my update of videoprogram Sony Vegas Movie Studio Platinum v.15.
After some cleaning up of my computer, everything seemed alright, ProTools 11 is still running (who would have thought) and every other software - except Pyramix (9.1.6).

So, down to some reinstalling, went without errors. Not working, Pyramix will not even try to start, no error message, no nothing. It doesn´t move.
I tried uninstalling and reinstallning a great many times, restarting windows several times in between (I know, it sometimes helps), nothing.
Tried installning v. 10 (I prefer to use 9.1 as I have a desktop 32bit system also), and Pyramix tries to start up but failes halfway (after running through VST´s etc.).

Seems like something is missing but I don´t know what or where to look for it.

Since the installers are going through without a problem, I don´t really know how to fix my system - everything else is running fine on the computer and I (regrettably) don´t have a system restore disc. I´d hate to restore from scratch and install everything... I´d rather buy another computer actually.

Any help?

Re: Failing to (re)install Pyramix

Posted: Sat Dec 01, 2018 20:01
by OlleGrane
After several attempts to reinstall I now no longer can input my MTPersonalkey into MT Security, I get the message:
"An internal exception occured (Adress:0x402c32b5) Please, contact Thank you!"

I have distant memories of getting this in the past, can´t remember how I got around it...
I´ve had similar issues before and I think I stumbled on a solution in the way of running the installer by right-clicking and selecting to "run as administrator" or something, although this doesn´t seem to make a difference this time.
I seriously hate doing this kind of hit and miss installation work... :roll:

Re: Failing to (re)install Pyramix

Posted: Sat Dec 01, 2018 21:47
by tonzauber

Re: Failing to (re)install Pyramix

Posted: Sat Dec 01, 2018 23:54
by OlleGrane
Thanks for chiming in!
- No, I did not try MTCleanup and I had totally forgot about it... wonderful!
- Now I´ve tried the MTCleanup, unfortunately didn´t change matters much - except I can enter my MTPersonalkey again.
Installation is still running smoothly without hiccups, it´s just that Pyramix won´t start.
It seems like it´s trying to start for a second, if I click the Pyramix start button again shortly after the first attempt I get the usual message "one instance is already running" but nothing more.
Also, when I look in one of my project folders, the pmx-file is blank white, without the Pyramix-logo that usually symbolizes the projekt file button.

Re: Failing to (re)install Pyramix

Posted: Sun Dec 02, 2018 05:09
by aomahana
Hi there,

I also use V9.1 so as to read my Akai DD project files.

And as well, the current Version 11, which had an issue opening, (with Windows 7).
This was because I was using Windows Classic Theme.
I changed to Windows Basic, and Pyramix would start.
This should only be an issue from 11.1 on, but if you are using Windows Classic theme with Win 7, try changing the theme to see if it helps.
Here is the link to the Merging notes .... ... ash+screen

All the best.

Re: Failing to (re)install Pyramix

Posted: Sun Dec 02, 2018 10:58
by OlleGrane
Thanks Aomahana!
I was already using the Windows Basic theme and that worked allright prior to my pc cleaning.
Thanks for the notes, I went through them to set up everything (again) but still no response.
I remember I did something stupidly simple last time I had a similar issue, but can´t think of what it was and can´t find any notes of it either...

Anyway, thanks for your input!

Re: Failing to (re)install Pyramix

Posted: Sun Dec 02, 2018 17:14
by fl
Since you mentioned "stupidly simple" (and perhaps easy to forget)...

Have you called up MTControl Panel to tell Pyramix to look for the Babyface? Or do whatever is required to connect it to your Hapi?

If Pyramix can't find an audio interface, it won't start. You could try installing ASIO4All to try to use your computer's internal sound hardware, just as a fallback test, in case the issue is with your connections/drivers for the external devices.

Also, you mentioned that the stoppage seems to occur when it's scanning the VST plug-ins. What happens if you temporarily remove all of them from your regular plug-in folder?

Re: Failing to (re)install Pyramix

Posted: Mon Dec 03, 2018 23:20
by OlleGrane
Thanks for your input Frank!
But yes, I´ve done the VS3 control panel setup as well, tried both my RME Babyface and the Merging HAPI interfaces. Also, I can´t start the Ravenna Easy Connect and my pmx-files are blank white squares, not recognizing Pyramix at all.
I mentioned trying run Pyramix 10 (I usually run 9.1.6 since my desktop is still running 32 bit windows and I want to move projects between the laptop that currently has a problem and the all working desktop) and it went a little further in starting up Pyramix, but there seems to be something else that is keeping Pyramix from installing correctly and I don´t think it´s because of VST´s - they are all the same that worked prior to my PC Clean... no new strange ones.
But all good, I need all the input I can get, it might trigger something.


Re: Failing to (re)install Pyramix

Posted: Tue Dec 04, 2018 17:08
by fl
Perhaps I've misunderstood, but are you saying that you've tried to install Pyramix 10 on a 32 bit Windows system? That'd do it...
If I'm wrong, and you're running Windows with the proper "bittedness" for the version of Pyramix in question, then, well, oops.

Was there an installation log created from when you did the initial cleanup during the Vegas update? That might show what was removed or replaced that crippled Pyramix. Failing that, you might find some help in the Pyramix Knowledge Base, specifically: ... ash+screen (note that this is a different page from the one suggested by aomahana)

and worst coming to worst, ... MT+Cleanup
which you've already attempted, but the page gives some good information about what to backup prior to using the tool (in case this ever happens again).

I'm in a similar position to what you have, although I do not have Vegas. For location recording, I have an older MacBook Pro running Windows 7 32 bit, with Pyramix 9 (with the Windows Classic Theme). My home computer is a Mac Mini, running Windows 7 64 bit with Pyramix 11.1.5 currently installed and working (works best with the Aero Theme). I do have to change the license key in my dongle every time I change systems, but that just takes as few seconds, as I'm sure you know. The only time I've encountered difficulty transferring projects from the Pyr9/Win7 32 to the Pyr11/Win7 64 system, is when I've needed to use the File Recovery Utility - where I encounter difficulties using the 64 bit version on the 64 bit machine, whereas recovering files created on the same machine (32 bit) as where they were created - always works.

For backups, I use a two part strategy every Saturday morning: the built-in Windows "Backup & Restore" utility, which will make both a file-by-file copy of your drive, as well as a full image of the entire partition. For the second part, and since I'm using Macs, I use a Mac based app called WinClone which makes a full image of my Windows partition. (Yes, my hind-quarters have been saved many times because of this.) Since you use PCs only, you might want to look into something like Acronis ( for additional backups - I've seen nothing but good reviews for this program, some from this forum.