wave form graphic disappears when zooming in. How do I fix?

Pyramix Native users forum
Forum rules
The Merging Technologies team cannot be held responsible for support queries logged on the public forums. If a support query is logged here and only here, it may not be found and dealt with by the appropriate team.
To ensure that your support issue or bug report is dealt with properly and in good time, please use the link to the tech support request form page on the Merging website.
Make sure to let us know what version you are using when you send your mail. THANKS!

wave form graphic disappears when zooming in. How do I fix?

Postby destinationsound » Mon Jul 10, 2017 23:30

Hi all,
So I have been able to zoom in all the way in the past to do an edit and still see the wave form graphic. However, sometime in the past week or so I can only zoom to a certain point and then the wave form goes blank.

I'm using Pyramix with DSD256 and am using software Pyramix ver 9.1.8

Is there a setting somewhere to fix this issue?

Thank you for the help
destinationsound
 
Posts: 4
Joined: Mon Jul 10, 2017 23:26

Re: wave form graphic disappears when zooming in. How do I f

Postby charlienyc » Thu Jul 13, 2017 19:43

Sorry you're having this trouble. What have you tried in terms of troubleshooting? Have you tried deleting the .pk2 waveform files? You can also delete the quickmount.pml files.

Also since this is a general Pyramix question, you could post your question in the General forum instead of Native.

cheers,
-Charlie
2x MassCore v10.1.4 Win7/64 i5-3450
3x Horus w/3 AD8p, 6 AD8, 1 DA8, 2 DA8p
Native v10.1.4 Win7/64 Pro i7 HP
Native v10.1.4 Win10 Bootcamp Mac Mini i5-4278U 2.6GHz
Native V8.1 Win7/32 Xeon 3520 2.67GHz RME HDSP MADI
Native V8.1 Win7/32 ThinkPad R61
User avatar
charlienyc
 
Posts: 329
Joined: Wed Aug 16, 2006 22:40
Location: chicago, il

Re: wave form graphic disappears when zooming in. How do I f

Postby fl » Thu Jul 13, 2017 20:01

My 2 cents: Do try Charlie's idea of deleting the pk2 and Quickmount files, but DON'T do this while Pyramix is running with your Project loaded. Close the project first, then try this idea. When you re-open you may have to right click on what appears as completely blank media in your Timeline, to select "Display > Generate Image". After a few moments, the waveform should be shown - hopefully at all zoom levels.

For best results, tell us what exactly you have selected in the main View Menu > Waveform Display sub-menu. Some settings might get funky when you zoom in a lot.

Also, you wouldn't be running with an NVDIA graphic engine on your machine, would you? There have been problems with NVDIA products, especially those which switch between different engines depending on demand. Pyramix doesn't like that.
Frank Lockwood, Toronto, ON, Canada
http://LockwoodARS.com
Native 11.0.5/Native Music 9.1.10
Win7 Pro SP1 64/32
Bootcamp 5.1.5621/4.0.4033
Mac Mini 6.2 (Quadcore i7)/MacBook Pro 3.1 (Core2Duo)
RME Fireface 800, driver version 3.122
User avatar
fl
 
Posts: 1195
Joined: Sun Feb 11, 2007 19:55
Location: Toronto, Ontario, Canada

Re: wave form graphic disappears when zooming in. How do I f

Postby destinationsound » Thu Jul 13, 2017 23:23

fl wrote:My 2 cents: Do try Charlie's idea of deleting the pk2 and Quickmount files, but DON'T do this while Pyramix is running with your Project loaded. Close the project first, then try this idea. When you re-open you may have to right click on what appears as completely blank media in your Timeline, to select "Display > Generate Image". After a few moments, the waveform should be shown - hopefully at all zoom levels.

For best results, tell us what exactly you have selected in the main View Menu > Waveform Display sub-menu. Some settings might get funky when you zoom in a lot.

Also, you wouldn't be running with an NVDIA graphic engine on your machine, would you? There have been problems with NVDIA products, especially those which switch between different engines depending on demand. Pyramix doesn't like that.



Thanks for the advice guys. After deleting and redrawing, the new wave forms are solid white blocks. Looks like it did something weird with the redraw.

Maybe try deleting again?
destinationsound
 
Posts: 4
Joined: Mon Jul 10, 2017 23:26

Re: wave form graphic disappears when zooming in. How do I f

Postby charlienyc » Thu Jul 13, 2017 23:55

destinationsound wrote:Maybe try deleting again?


It wouldn't hurt. Does the sampling rate of the project match the media? I can't think of any other reason for these waveforms to misbehave, save for the graphics card issues Frank mentioned.
2x MassCore v10.1.4 Win7/64 i5-3450
3x Horus w/3 AD8p, 6 AD8, 1 DA8, 2 DA8p
Native v10.1.4 Win7/64 Pro i7 HP
Native v10.1.4 Win10 Bootcamp Mac Mini i5-4278U 2.6GHz
Native V8.1 Win7/32 Xeon 3520 2.67GHz RME HDSP MADI
Native V8.1 Win7/32 ThinkPad R61
User avatar
charlienyc
 
Posts: 329
Joined: Wed Aug 16, 2006 22:40
Location: chicago, il

Re: wave form graphic disappears when zooming in. How do I f

Postby fl » Fri Jul 14, 2017 13:53

destinationsound wrote:After deleting and redrawing, the new wave forms are solid white blocks.

White? That's certainly unusual. What is the state of vertical zoom? If the waveforms are too "tall" they can sometimes appear as solid blocks.

Did you force a waveform re-draw? Sometimes it doesn't happen automatically. While it's working, you should see something like a count-down in the lower right corner of the main window, while Pyramix is busy re-drawing.

The only other thing I can think of is that the Waveform display button in the Track Header (second from the right, in the second row of buttons) somehow got switched from "Waveform" to "Text Only" which, as its name suggests, shows no waveform. It should have a grey background with a white "W" on it.

If none of this brings any solution, you might want to try running the Pyramix installer once again, this time in "Repair" mode (one of the options made visible when the installer determines that Pyramix is already installed), and re-booting. If that brings no satisfaction, then perhaps it's time to contact Merging Support directly for assistance.
Frank Lockwood, Toronto, ON, Canada
http://LockwoodARS.com
Native 11.0.5/Native Music 9.1.10
Win7 Pro SP1 64/32
Bootcamp 5.1.5621/4.0.4033
Mac Mini 6.2 (Quadcore i7)/MacBook Pro 3.1 (Core2Duo)
RME Fireface 800, driver version 3.122
User avatar
fl
 
Posts: 1195
Joined: Sun Feb 11, 2007 19:55
Location: Toronto, Ontario, Canada

Re: wave form graphic disappears when zooming in. How do I f

Postby destinationsound » Fri Jul 14, 2017 22:49

Thanks for the help all!

Wave form height is not the problem. might need a Pyramix reinstall.

here is a link to some screenshots of what we are experiencing and some extra info.

https://drive.google.com/drive/folders/0B9svhg4RWAdXeExpZUhHcWswTUE?usp=sharing
destinationsound
 
Posts: 4
Joined: Mon Jul 10, 2017 23:26

Re: wave form graphic disappears when zooming in. How do I f

Postby fl » Sat Jul 15, 2017 13:36

Well, that's a stumper, for sure. The only thing I can suggest after seeing your screen-shots, is for you to try changing the setting in the Main Settings > Application > Timeline Layout > Display Clip Text, from its current setting, to "In Front" (or Behind). Does that make any difference?

Also, the "Encountered Improper Argument" message is troubling. Is your Windows install up to date? Microsoft has been publishing several faulty updates in the past couple of years - did all this start happening after a Microsoft, or Display Driver update? I've never trusted Device Driver updates coming from MS, preferring to go directly to the hardware manufacturer's website for any and all driver updates. Since you're running version 9 (do I have that right?), it could be a more recent update which is causing a problem with Pyramix. I'd certainly try reinstalling Pyramix in "Repair" mode, but beyond that I think you need to take it up with Merging Support, perhaps with a TeamViewer session so they can see what's going on under the hood, so to speak.
Frank Lockwood, Toronto, ON, Canada
http://LockwoodARS.com
Native 11.0.5/Native Music 9.1.10
Win7 Pro SP1 64/32
Bootcamp 5.1.5621/4.0.4033
Mac Mini 6.2 (Quadcore i7)/MacBook Pro 3.1 (Core2Duo)
RME Fireface 800, driver version 3.122
User avatar
fl
 
Posts: 1195
Joined: Sun Feb 11, 2007 19:55
Location: Toronto, Ontario, Canada

Re: wave form graphic disappears when zooming in. How do I f

Postby charlienyc » Mon Jul 17, 2017 17:09

Seeing these screenshots, I'm guessing this has something to do with the EasyConnect error and media types. Definitely contact support@merging.com if you haven't done so already, and include a link to the screenshots. They should have you back up and running fairly quickly.
2x MassCore v10.1.4 Win7/64 i5-3450
3x Horus w/3 AD8p, 6 AD8, 1 DA8, 2 DA8p
Native v10.1.4 Win7/64 Pro i7 HP
Native v10.1.4 Win10 Bootcamp Mac Mini i5-4278U 2.6GHz
Native V8.1 Win7/32 Xeon 3520 2.67GHz RME HDSP MADI
Native V8.1 Win7/32 ThinkPad R61
User avatar
charlienyc
 
Posts: 329
Joined: Wed Aug 16, 2006 22:40
Location: chicago, il


Return to Pyramix Native

Who is online

Users browsing this forum: No registered users and 3 guests