Cannot use Ravenna ASIO Driver on Windows 10 (with Hapi)

Pyramix Native users forum
Forum rules
The Merging Technologies team cannot be held responsible for support queries logged on the public forums. If a support query is logged here and only here, it may not be found and dealt with by the appropriate team.
To ensure that your support issue or bug report is dealt with properly and in good time, please use the link to the tech support request form page on the Merging website.
Make sure to let us know what version you are using when you send your mail. THANKS!
Posts: 9
Joined: Sat Dec 20, 2014 10:31

Cannot use Ravenna ASIO Driver on Windows 10 (with Hapi)

Postby buggyboy » Tue Dec 20, 2016 22:11

I have a PC that was running fine on Windows 7 connected to my Hapi. After moving to Windows 10 Pro x64, I cannot get any ASIO host to use the Ravenna driver.

The Hapi is directly connected to an Intel Gigabit CT Desktop network card (the PC is also connected to a router for Internet access with the network card integrated to the motherboard).

Hapi is running the latest firmware 3.5.0_31364. The ASIO driver is also the latest version 10.1.2__Build30443_x64. I tried to reboot the Hapi, and even flash that firmware again, reboot to factory settings, without any positive result.

UAC is set to minimum.
Firewall is turned off.
It is a fresh Win 10 install (even reinstalled win10 on top of itself to be sure), with just the motherboard (Asus X99A) and network card drivers installed.
The Device Manager doesn't show any question mark, so all necessary drivers should be installed.

Hapi is visible on MT Discovery (and accessible through the web interface).
The Raveanna ASIO panel is configured with the proper network card. But It shows a 44.1 rate even with the Hapi itself configured for 96 or something else.
Easyconnect doesn't show the Hapi, everything stays grayed out on the right side (and the left too). When starting Easyconnect, a notification says that Hapi is discovered.

Any ASIO host I use (Foobar, Voicemeeter, JRiverMediaCenter,...) reports an impossibility to access the Ravenna driver, either when trying to play a file or to configure the driver.

I think I installed everything by the book, Win10 is supported, it should work like it does on Win 7, I spent a huge amount of time reinstalling, checking everything I could think of.... I don't know what to do anymore. Any help would be greatly appreciated.

Thank you in advance,

Edit : Program Manager shows that the Ethernet card connected to he Hapi is receiving 1,7 Mb/s whenever the Ravenna ASIO Control Panel is running. That doesn't look normal :(

Edit 2: Some Progress: out of despair, I downloaded a test version of Samplitude, and it works fine! But still no hope for other hosts that I'm more interested in. One difference : Samplitude is a 64 bit app, the other tested hosts are not. Could this have a role and be the problem? (Even if using only 64 bit hosts cannot be a solution for me))

Edit 3 : searching for 64 bit players for some more testing, I installed Signalyst HQPlayer and it sort of works.
I do get ASIO connection and sound, but I cannot use the channel mapping feature. With bi-amplification, I remap stereo sources to 8 channels L/R/L/R/L/R/L/R. HQPlayer cannot access the Ravenna driver when channel remapping is on.
I have the same problem in Foobar : Foobar ASIO configuration cannot access the Ravenna driver to remap channels. That was working under Win7.
The 32 bit version of HQPlayer doesn't work with Ravenna, no connection, and of course no sound. It works with a RME ASIO driver though (so it can work on a 64 bit OS, as expected). That seems to confirm that under Win10, Ravenna ASIO driver would have a problem with 32 bit players?

Posts: 9
Joined: Sat Dec 20, 2014 10:31

Re: Cannot use Ravenna ASIO Driver on Windows 10 (with Hapi)

Postby buggyboy » Wed Dec 21, 2016 18:51

Well, turns out that the C++ runtime library was only installed with its 64 bit flavor and the x86 part was missing. As a result, 32 bit hosts could not access the Ravenna ASIO driver. It had to be downloaded ( ... px?id=5555 ) and installed separately.

Everything is working fine now, thanks to Guillaume's help, great job ! :)

Posts: 416
Joined: Wed May 26, 2010 05:26
Location: Brisbane, Australia

Re: Cannot use Ravenna ASIO Driver on Windows 10 (with Hapi)

Postby DJS » Fri Dec 23, 2016 01:22

buggyboy wrote:Everything is working fine now, thanks to Guillaume's help, great job ! :)

Nice to see Merging supporting W10.
David Spearritt
Classical and Acoustic Music, BNE, Australia