Pyramix X Clip Render troubles

Pyramix Native users forum
Forum rules
The Merging Technologies team cannot be held responsible for support queries logged on the public forums. If a support query is logged here and only here, it may not be found and dealt with by the appropriate team.
To ensure that your support issue or bug report is dealt with properly and in good time, please use the link to the tech support request form page on the Merging website.
Make sure to let us know what version you are using when you send your mail. THANKS!

Pyramix X Clip Render troubles

Postby ckalcov » Mon Jan 18, 2016 22:46

Hi all,

I made the upgrade to Pyramix 10 this weekend and I have a feeling that the Render function isn't working as it was in v9.

Usually when I want to run off a track or two (for example the PGM mix) from a large multitrack PMF, I select all the clips on those tracks and go to Render > (None) > Selection (split by groups) to run those tracks off, split into takes. However when I do this, it seems to run off the entire multitrack for each clip group/take, not just those selected channels. Is there a fix on the horizon?

I haven't tried using 'render only solo tracks', but it isn't a great workaround as it would output one file per track which for stereo renders isn't ideal...

Many thanks
CK

EDIT: I should also mention that I'm running Native, V10.0.6.
ckalcov
 
Posts: 8
Joined: Mon Jan 18, 2016 22:38

Re: Pyramix X Clip Render troubles

Postby ckalcov » Fri Jan 22, 2016 16:46

Another curious development that may or may not be related - when I try to Mix Down a selection in MP3 format, it tells me that it's "unable to create file 'xyz'" and aborts the mix down. The workaround for the time being has been to mark up a CD and export as a Digital Release in MP3 format...

Session project at 96kHz, with SRC presumably enabled by default for export to MP3, nothing odd looking in the export dialog?
ckalcov
 
Posts: 8
Joined: Mon Jan 18, 2016 22:38

Re: Pyramix X Clip Render troubles

Postby avi » Sun Jan 24, 2016 10:50

Do your Pyramix files have "unique file identifier" turned off? If the media name and the desired rendered media name (i.e. "Take 001" and "Take 001") are identical then PMX has had issues creating the new file. (I vaguely recall a time when it would not only abort the render, but would also somehow delete the existing file with the same name too, but that was some time ago.)
If names need to be the same, set a different destination directory for the renders. If UFID is "on" then this shouldn't be an issue and it's a different problem.
Alexander Van Ingen
Six Music Productions
www.sixmp.co.uk
avi
 
Posts: 308
Joined: Mon Nov 08, 2004 00:10
Location: London, UK

Re: Pyramix X Clip Render troubles

Postby ckalcov » Sun Jan 24, 2016 18:38

Hi Alex,

Hope all's well, thanks for the tip. I just ran a test in the Render dialog and discovered that conversely when clips are ungrouped, the render exports single tracks regardless of selection. However, when you use 'Selection' rather than 'Selection (split by groups)', the correct tracks are exported but of course not split by groups - as it should. So it's a new problem for V10 with the 'split by groups' export option.
Toggling UFID doesn't seem to make a difference in this case.

I also tried repeating the issues I had with the Mix Down dialog but it seems to now be working, I'm not entirely sure why! It also seems to be happy to work regardless of UFID, but either way that's very good to know.
ckalcov
 
Posts: 8
Joined: Mon Jan 18, 2016 22:38

Re: Pyramix X Clip Render troubles

Postby ckalcov » Tue Dec 13, 2016 14:49

Hello again,

Just bumping this post as it's still an issue as of the latest update, where selection split by groups still exports the whole multitrack regardless of selection...

Perhaps I need to create a new track group for what I want to export instead?
ckalcov
 
Posts: 8
Joined: Mon Jan 18, 2016 22:38

Re: Pyramix X Clip Render troubles

Postby avi » Tue Dec 13, 2016 15:22

I've just re-read your question(s).

(1) I don't think the PMX render function to mp3 has ever worked a >48k. So at 96k, use album publishing. Or render as PMF / WAV, whatever; SRC to 44k1 / 48k, and then render as MP3. A bore, I know.

(2) I thought the render / split by groups had always worked that way. Render will do all the tracks that are grouped.
In "Selection / split by groups" the 'selection' is only relevant to define the in and out points from L to R in the timeline; it'll then render everything within that time area as per grouping.

You could select all, ungroup, then select the first take of PGM R, and probably build a macro to go through re-grouping the stereo channels. ( TBH I'd avoid ungrouping / re-grouping as PMX has played funny games with that in previous versions and somewhere mid-edit you'll realise that one track hasn't been following along...)

But that's a bit of a faff.
* So... If you want to get stereo out, either use Mix Down (if the mix is in the PMX mixer); or the cleanest, easiest solution:
save the project with a new file name, and delete all tracks except PGM L and PGM R; then you can select all (or as relevant), and render / split by group. Not only is that easy, there's no room for error either :-) *
Last edited by avi on Fri Dec 30, 2016 23:00, edited 1 time in total.
Alexander Van Ingen
Six Music Productions
www.sixmp.co.uk
avi
 
Posts: 308
Joined: Mon Nov 08, 2004 00:10
Location: London, UK

Re: Pyramix X Clip Render troubles

Postby ckalcov » Fri Dec 30, 2016 20:24

avi wrote:delete all tracks except PGM L and PGM R; then you can select, and render / split by group. Not only is that easy, there's no room for error either :-)


A brilliant idea. Why didn't I think of that? :P

Yes, come to think of it all the cases I had to export PGM were at 48kHz - good to know. Thanks again.
ckalcov
 
Posts: 8
Joined: Mon Jan 18, 2016 22:38


Return to Pyramix Native

Who is online

Users browsing this forum: No registered users and 2 guests