Auto-crossfade, also 16 bit mixdown output

Pyramix Native users forum
Forum rules
The Merging Technologies team cannot be held responsible for support queries logged on the public forums. If a support query is logged here and only here, it may not be found and dealt with by the appropriate team.
To ensure that your support issue or bug report is dealt with properly and in good time, please use the link to the tech support request form page on the Merging website.
Make sure to let us know what version you are using when you send your mail. THANKS!
Rob
Posts: 31
Joined: Sat Mar 30, 2013 22:34
Location: San Francisco, CA

Auto-crossfade, also 16 bit mixdown output

Postby Rob » Tue Feb 17, 2015 02:18

What is the magic to get auto-crossfade to work? I have read every scrap of info on the subject that I can find but it still does not work. I'm talking about pushing one clip into another and getting an auto-crossfade. Same for dropping a clip on another.

I cannot get 16 bit output to work in the mixdown function either. With source material at 96k/24b I set output to 44.1k/16b wav file and it delivers 44.1k/24b every time.

This is with Pyramix 9 Master Native latest build.

Any clues appreciated.
- rob
Pyramix 10 Native Master on a MBP Retina Bootcamp partition running Windoze 7 64bit, Horus with 32 premo inputs and 8 premo outs and Hapi with new AKD8DP.

User avatar
fl
Posts: 1291
Joined: Sun Feb 11, 2007 19:55
Location: Toronto, Ontario, Canada
Contact:

Re: Auto-crossfade, also 16 bit mixdown output

Postby fl » Tue Feb 17, 2015 21:51

Rob wrote:What is the magic to get auto-crossfade to work? I have read every scrap of info on the subject that I can find but it still does not work. I'm talking about pushing one clip into another and getting an auto-crossfade. Same for dropping a clip on another.


There are two places to enable Auto-crossfading - in the Settings > Application > Editing window, and in the main window's Edit Menu (way at the bottom). This is another situation where settings in Settings and settings in a Menu item are similarly named, interdependent, confusing and easy to miss.

With "Auto-crossfade by Default" disabled in the Settings, but "Auto-crossfade" enabled in the Edit menu, moving a clip in the Timeline over top of another clip will replace the overlapped section of the unmoved Clip with the moving Clip, and will place the Default Crossfade at the join. (Default Crossfade is determined and saved in the Crossfade Editor tab/window.) With Auto-crossfade disabled in the Edit menu, much the same thing happens, except the join is a butt splice. Control-clicking and dragging a Clip over top of another clip will create a crossfade for the entire duration of the overlap, which is the way it's always worked.

With "Auto-crossfade" enabled in the Edit Menu, Copying and pasting in the timeline, results in default crossfades at either end of the newly pasted material. Pasting will either overwrite or ripple, depending on the Edit menu's "Auto-ripple" setting (which is also hidden down near the bottom of the Edit menu).

When performing a Source-Destination edit, having "Auto Crossfade" enabled in the Edit Menu will automatically place the default crossfade at the joins resulting from any Auto-edit process. This is all as expected, and how I prefer to work.

With "Auto-crossfade by Default" enabled in the Settings, things are very buggy and should be reported as such directly to support@merging.com. Here, dragging a clip over another results in both the overlapping clips playing simultaneously. The Edit menu's "Auto-crossfade" behaves as normally as can be expected in this unusual situation.

I cannot get 16 bit output to work in the mixdown function either. With source material at 96k/24b I set output to 44.1k/16b wav file and it delivers 44.1k/24b every time. This is with Pyramix 9 Master Native latest build.


I was initially able to recreate this problem, but after a few tries, things started to behave properly (the coder's favourite kind of bug, I'm sure). The new Mixdown window, as of version 9, is not as elegant as you might hope, with lots of little "gotchas" waiting for you. To mix to a different sample rate than the session's, the checkbox (on the right) for "SRC and Redithering" should be checked with the appropriate output settings selected - AND - the "Media Wordlength" drop-down (in the middle) should be set to the desired wordlength. Yes, I have managed to create 16 bit files in this way. With the SRC and Redithering checkbox de-selected, the mixed output will be at the session sample rate, but the wordlength will again be determined by the "Media Wordlength" drop-down. It may be that you have to toggle both these settings a couple of times before it "takes", especially when you've just launched the program and opened a session. Like the auto-solo playback in a Source-Destination session, it takes a few clicks back and forth to get things working properly.

To further illustrate the buggy condition of the Settings > Application > Editing > "Auto Crossfade by Default" being enabled, with the situation where a dragged clip is now overlapping another clip, so that both play simultaneously (incorrectly), mixing down between the red and green Marks to whatever output format results in a file containing only the "on-top" clip, no matter where you place the marks. Mixing down the whole composition results in a file with the overlap audible. At this point my head hurts.

Short answer: the Edit menu's "Auto-crossfade" is works properly, but is almost hidden way down near the bottom of the long Edit menu. The Settings' "Auto-crossfade by Default" is buggy and should be avoided. You can mix to 44/16 from a 96/24 session, provided all the settings are correct in the Mixdown window, but you may have to try a few times before it "takes".
Frank Lockwood, Toronto, ON, Canada
http://LockwoodARS.com
Native 11.1.5
Win7 Pro SP1 64
Bootcamp 5.1.5621
Mac Mini 6.2 (Quadcore i7)
RME Fireface 800, driver version 3.125

User avatar
Graemme
Posts: 2204
Joined: Wed May 15, 2002 22:18
Location: Vancouver, BC, Canada
Contact:

Re: Auto-crossfade, also 16 bit mixdown output

Postby Graemme » Wed Feb 18, 2015 06:30

I've had "Auto Crossfade by Default" enabled for something like ten years with no problems...

For Auto-Xfade to work on my system I drag one clip towards another and *then* press the CTRL key...et voila, "Auto X-Fade"

The Pyramix mixer and Mixdown window are distinctly separate and I appreciate this apparently more cumbersome approach, as it lets me perform a real-time mixdown at 16 bit while sending a 24-bit version through external processing, etc.
Graemme Brown
Zen Mastering
1460 Wild Rose Drive
Gabriola Island, BC
Canada V0R 1X5
+1.604.874.9096

"A Horus, A Horus; My Kingdom for a Horus!"

Rob
Posts: 31
Joined: Sat Mar 30, 2013 22:34
Location: San Francisco, CA

Re: Auto-crossfade, also 16 bit mixdown output

Postby Rob » Sat Feb 21, 2015 00:29

Thanks for the tips guys, I appreciate it. All is working now.
- rob
Pyramix 10 Native Master on a MBP Retina Bootcamp partition running Windoze 7 64bit, Horus with 32 premo inputs and 8 premo outs and Hapi with new AKD8DP.