HAPI + ASIO device latency?

Pyramix Native users forum
Forum rules
The Merging Technologies team cannot be held responsible for support queries logged on the public forums. If a support query is logged here and only here, it may not be found and dealt with by the appropriate team.
To ensure that your support issue or bug report is dealt with properly and in good time, please use the link to the tech support request form page on the Merging website.
Make sure to let us know what version you are using when you send your mail. THANKS!

HAPI + ASIO device latency?

Postby OlleGrane » Wed Dec 31, 2014 23:40

Hi!

I´m expecting my HAPI interface anytime soon now but am eager to hear your experience using the Horus / Hapi interfaces in combination with ASIO interfaces?!
My plan is to use the HAPI for location recording work with my RME Babyface as my location control room monitor and talkback system.
I suppose the HAPI / Ravenna will have a lot lower latency than the ASIO, but I wonder - will the use of the ASIO affect the latency of the HAPI?
For controlroom monitor and talkback, latency is not an issue but I need the HAPI to be as fast as possible to send headphone cues back to the artist...

Buying a second HAPI for monitor / talkback purposes alone is a bit expensive... :roll:

/Olle
Olle Grane
Green Hat Music & Sound

Pyramikx V9.1 Native
Win 7 PC according to the Merging spec of june 2010 with RAID 1+0 audio drive 1TB
HP Elitebook 8440p native
Merging HAPI / RME Babyface interfaces
OlleGrane
 
Posts: 28
Joined: Mon Sep 29, 2008 19:15

Re: HAPI + ASIO device latency?

Postby AndrewB » Fri Mar 13, 2015 04:33

OlleGrane wrote:For controlroom monitor and talkback, latency is not an issue but I need the HAPI to be as fast as possible to send headphone cues back to the artist...


As far as the fastest solution for headphone cues, the Direct output AD cards have direct analogue outputs, that is to say, zero latency. On location would then require some sort of mixing board to provide the headphone mix.

As far as headphone cue mix from software, it looks like you are using MassCore, and the latencies are posted in the manual. You will have to refer to someone else to know for sure if a secondary-ASIO monitoring device changes latency times for the primary MassCore device (my assumption is no).

Given this post is in the Native forum however, perhaps you are using ASIO-Ravenna drivers. I'm unclear where the latency numbers are posted on this (it would be good to know). In addition the same question remains: will the secondary-ASIO device alter the (primary) ASIO-Ravenna latency. Further more, I recall that the secondary-ASIO device was intended more for the MassCore user....
Last edited by AndrewB on Fri Mar 13, 2015 04:54, edited 2 times in total.
User avatar
AndrewB
 
Posts: 97
Joined: Sat Aug 03, 2013 06:24
Location: Ottawa, Ontario, Canada

Re: HAPI + ASIO device latency?

Postby AndrewB » Fri Mar 13, 2015 04:39

Yes , my recollection seems to be on the money. According to Graemme, secondary-ASIO device is intended for MassCore.

See the following link for more discussion on Secondary audio device:
viewtopic.php?f=54&t=10177
User avatar
AndrewB
 
Posts: 97
Joined: Sat Aug 03, 2013 06:24
Location: Ottawa, Ontario, Canada

Re: HAPI + ASIO device latency?

Postby OlleGrane » Sat Mar 14, 2015 15:41

Hi Andrew!
Thanks for your reply!

Yes, I use a large and heavy desktop system with masscore and RAID (10), but also a native laptop that has up to now been a small B-rig with RME Babyface and a RME OctamicD.
I´m not really sure I need masscore, but I already got the license and the Masscore card isn´t very expensive.

I just got the HAPI up and running by itself now, have to look into the other stuff later.

I bought the HAPI pre installed with the new 8i/o card, but the 8 input / direct out card seems to be the logical choice as an upgrade for the second port.
A small portable controll room interface as mentioned in other threads would of course be the best solution I think, for talkback and monitor.

Getting into the world of networked audio is thrilling, scary and all very new to me... :oops:
Olle Grane
Green Hat Music & Sound

Pyramikx V9.1 Native
Win 7 PC according to the Merging spec of june 2010 with RAID 1+0 audio drive 1TB
HP Elitebook 8440p native
Merging HAPI / RME Babyface interfaces
OlleGrane
 
Posts: 28
Joined: Mon Sep 29, 2008 19:15

Re: HAPI + ASIO device latency?

Postby OlleGrane » Fri Mar 27, 2015 11:09

I have now tested running the two interfaces in "Secondary Device" mode (the HAPI and the RME Babyface as control room) on my Native laptop system.
It works great for monitoring, in ASIO the RME has very slight latency but without the option to run an input (talkback mic). In Windows Audio or Direct Sound there is a huge latency of more than a second but still, it works!

Unfortunately I don´t get the input to work even though I can select it in the All Settings / Secondary Device Setup.
When I try to select AB1 as source in the Talkback setup I just get the input 1 of the HAPI instead!?
I must be missing out on something here... something in the talkback setup? Windows Audio setup?
I´ve tried different settings, the laptops internal mic, running the RME i/o in Windows Audio or Direct Sound. Nothing works.

Any suggestions?

Otherwise I must say I´m very impressed with the HAPI. First gig next week! :D
Olle Grane
Green Hat Music & Sound

Pyramikx V9.1 Native
Win 7 PC according to the Merging spec of june 2010 with RAID 1+0 audio drive 1TB
HP Elitebook 8440p native
Merging HAPI / RME Babyface interfaces
OlleGrane
 
Posts: 28
Joined: Mon Sep 29, 2008 19:15

Re: HAPI + ASIO device latency?

Postby brianlosch » Sat Jun 10, 2017 05:50

Hi Olle,

I know this thread is a few years old, but I came across it when finding the exact same issue regarding talkback using a secondary ASIO device (Hapi / RME Fireface). Were you able to have the MT ASIO Bridge inputs recognized in the Talkback section? I'm also having success with monitoring and receiving inputs in Pyramix from the MT ASIO Bridge, but the Talkback section defaults to ASIO inputs instead of ASIO Bridge (i.e. AB1 -> ASIO 1). This appears to be purely a software issue in the monitor section. Hopefully it's been fixed by now or perhaps there is a workaround...
brianlosch
 
Posts: 1
Joined: Sat Jun 10, 2017 05:39

Re: HAPI + ASIO device latency?

Postby OlleGrane » Sat Jun 10, 2017 20:55

Hi Brian!
I actually don´t remeber very well the results but I think they were poor.
I think I got it somewhat to work but not with asio but with some of the native Windows drivers and with several seconds of latency and not very stable - I gave up.
I´ve been running a long cat5-cable as multi to the HAPI and three channels of analog cable (talkback and headphones) to my makeshift control room and using the HAPI outputs for talent monitor / headphones.
It´s a bit sad, could have been an elegant solution for monitor and talkback, especially with the nice programmable talkback / monitor function in Pyramix.
Olle Grane
Green Hat Music & Sound

Pyramikx V9.1 Native
Win 7 PC according to the Merging spec of june 2010 with RAID 1+0 audio drive 1TB
HP Elitebook 8440p native
Merging HAPI / RME Babyface interfaces
OlleGrane
 
Posts: 28
Joined: Mon Sep 29, 2008 19:15


Return to Pyramix Native

Who is online

Users browsing this forum: Bing [Bot] and 2 guests